Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
LSLRobert

2008 LSV Sunscape, stereo uprade and panel issue, I may be screwed

Recommended Posts

LSLRobert
Posted (edited)

I really hope that your collective genius can help me out here!  First person to get it right gets $25 bucks cash sent via venmo, or drinks of your choice if we ever see each other:) 

2008 LSV.  Last year I had a few issues, the left "switch" panel quit working.  More specifically, the LED screen quit working.  You can kind of read something in some light, but the screen is dead.  However, the buttons work.  Weird. 

About the same time, but not necessarily the same time, the stereo quit working.  The boat has the factory JBL system with the black box (MBB-3) with a cabin remote and a separate transom remote.  See the attached pictures.  In addition, you can see the tower speakers in the picture.  Under the dash I have a Wet Sounds WS-420 equalizer.  Two amps, both wet sounds. 

I believe that the amps and equalizer are all working.  We can get some sound with certain settings.  

My stereo guy is suggesting that I replace the MBB-3 and remotes with something newer that has bluetooth.  I am ok with that but want to know what you guys recommend.  I don't need the best, something a few years old is fine so long as it works as close as possible to factory.  
 

The bigger issue is the left switch/annunciator panel.  See the picture attached with it circled in red.  He mentioned getting it "flashed" or reset but that was above his area of expertise.  

Suggestions fellow owners?  Timing sucks, money is tighter than ever with this pandemic crap so I don't want to replace every component if I don't need to.  

 

If the easiest thing to do is to keep the boat sound system completely separate from the factory panel/computer I can live with that but am hoping for a better option. 

Thoughts?

 

Wait, the pictures are not showing up.  How do I post a picture here folks!

Edited by LSLRobert

Share this post


Link to post
ahopkinsVTX

I’m not much help your your specific boat issues other than those screens have been known to fail. However, here is how to post a picture here:

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...