Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

G Spot

Downloading apps/music on the 2020 OS

Recommended Posts

dcarl

I sent an email to Navionics asking them to put the app on the Amazon app store, I doubt they will but worth a shot. 

 

Share this post


Link to post
Jeepman

For those with 2020 boats trying to fix the Amazon Music 20 seconds of playback then skips to next song issue, this is what fixed it for me:  Go to Settings -> Apps -> Amazon Music and uninstall the app.  Then in Settings go to Storage and clear your cache.  Then go to Amazon App Store and re-install the app.  Run Amazon Music, go to one of your playlists, select the three dots button, and download the playlist.  Wait for it to finish downloading before playing any songs, which can take a while.  To confirm it is now working, you have to disconnect from wifi (just "forget" your wifi network in Connection Settings) and play the playlist.  For me, the songs play to the end and all the album art is there now.  Before doing this, songs would only play for about 20 seconds or so (never timed it) and then skip to the next if I was not connected to wifi.  When I was connected to wifi it worked fine.  Hope this helps someone although I don't really know why this fixed it.  I was just shooting in the dark.

In related news: the Android OS environment appears to be virtualized inside the host OS of the dash.  The reason I say this is because my "Android" system keeps crashing but the rest of the dash OS is fine.  Did it at least six times today on the water.  I'm listening to Amazon Music inside the "Android" system and the music stops mid-song and the entire Android environment is just gone.  Blank screen.  No menu buttons, no response to touch, swipe, screaming at it, etc.  Everything on the dash works (both screens) but if you press the Android icon top right of the left panel you just get a blank screen.  It stays like this till you open the battery disconnect switch and then power everything up again.  Extremely annoying!

And while we (Ok, maybe just me) are ranting about the dash OS, I also have a bug where if I am floating with the screens on but the engine off for a while then go to start the engine I get nothing.  Pressing the start button does nothing at all.  Open battery disconnect, close it back, Medallion screen CPU boots up, press the start button, enter code, press start button again and all is well..... till the next time I stop and float for a while and it's dead again.  Pretty annoying and a little embarrassing honestly that I have to reboot my boat every hour or so to drive it.  I did notice the last time it did this the status of both CAN networks under Diagnostics were offline (No modules communicating) and the status of the "Start/Stop Switch" was "Pressed" which was incorrect but probably wrong because no valid CAN data available.  So I'm thinking the CAN network is dropping out for some reason.  But that doesn't completely make sense because the controls from the Grayhill knob to the radio and Medallion CPU module is all via CAN and that is working when the engine will not start.  All the CAN data to the power modules seems to work also.  The only symptom is no engine start.  Anyway, it is clearly a software bug because the start button works 100% of the time after cycling power to the boat and allowing all the modules to reboot.  Is this happening to anyone else?

I considered that my two issues may be related.  I will probably try the reset feature in the menu which I assume will completely wipe everything and take me back to an as-shipped configuration.  And if that doesn't fix it I'm gonna get the dealer involved because the no-start thing is really too much to just put up with.  

No OTA update is available according to the Software screen so either OTA updates are not working yet or I have the latest software.   Boat was built March 2020.  

Share this post


Link to post
ahopkinsVTX

Does anyone know if I make changes to a downloaded playlist on Spotify if I need to re-download or will it update automatically? I was in the driveway yesterday and it looked like the updates were there but I was also connected to wifi.

Share this post


Link to post
G Spot
3 hours ago, ahopkinsVTX said:

Does anyone know if I make changes to a downloaded playlist on Spotify if I need to re-download or will it update automatically? I was in the driveway yesterday and it looked like the updates were there but I was also connected to wifi.

Mine just updates automatically when I’m connected to WiFi and you must open up Spotify. Then I get the download icon. 

Share this post


Link to post
ahopkinsVTX
16 minutes ago, G Spot said:

Mine just updates automatically when I’m connected to WiFi and you must open up Spotify. Then I get the download icon. 

OK so maybe mine updated automatically yesterday too. Hopefully find out soon!

Share this post


Link to post
dcarl
On 5/15/2020 at 11:59 AM, dcarl said:

I sent an email to Navionics asking them to put the app on the Amazon app store, I doubt they will but worth a shot. 

 

Follow up quote from Navionics

"We do not make an APK available to third parties for use on android devices that are not google certified.
We are working with the hardware manufacturer that provides the navigation device to Malibu and the plan is to have the APK pre-loaded on their navigation device that is not Google certified.
This is based on Malibu’s production timeline for such a feature.
We have to send all requests/communication for such a feature to Malibu."

Anyone know who I could contact at Malibu to get this added?

By the way I loaded spotify and it works great.  Now I run spotify on the left screen and the maps on my phone.  

 

Share this post


Link to post
23LSVOwner
36 minutes ago, dcarl said:

Follow up quote from Navionics

"We do not make an APK available to third parties for use on android devices that are not google certified.
We are working with the hardware manufacturer that provides the navigation device to Malibu and the plan is to have the APK pre-loaded on their navigation device that is not Google certified.
This is based on Malibu’s production timeline for such a feature.
We have to send all requests/communication for such a feature to Malibu."

Anyone know who I could contact at Malibu to get this added?

By the way I loaded spotify and it works great.  Now I run spotify on the left screen and the maps on my phone.  

 

They are already working on it.

Share this post


Link to post
JBell
On 5/16/2020 at 10:38 PM, Jeepman said:

For those with 2020 boats trying to fix the Amazon Music 20 seconds of playback then skips to next song issue, this is what fixed it for me:  Go to Settings -> Apps -> Amazon Music and uninstall the app.  Then in Settings go to Storage and clear your cache.  Then go to Amazon App Store and re-install the app.  Run Amazon Music, go to one of your playlists, select the three dots button, and download the playlist.  Wait for it to finish downloading before playing any songs, which can take a while.  To confirm it is now working, you have to disconnect from wifi (just "forget" your wifi network in Connection Settings) and play the playlist.  For me, the songs play to the end and all the album art is there now.  Before doing this, songs would only play for about 20 seconds or so (never timed it) and then skip to the next if I was not connected to wifi.  When I was connected to wifi it worked fine.  Hope this helps someone although I don't really know why this fixed it.  I was just shooting in the dark.

In related news: the Android OS environment appears to be virtualized inside the host OS of the dash.  The reason I say this is because my "Android" system keeps crashing but the rest of the dash OS is fine.  Did it at least six times today on the water.  I'm listening to Amazon Music inside the "Android" system and the music stops mid-song and the entire Android environment is just gone.  Blank screen.  No menu buttons, no response to touch, swipe, screaming at it, etc.  Everything on the dash works (both screens) but if you press the Android icon top right of the left panel you just get a blank screen.  It stays like this till you open the battery disconnect switch and then power everything up again.  Extremely annoying!

And while we (Ok, maybe just me) are ranting about the dash OS, I also have a bug where if I am floating with the screens on but the engine off for a while then go to start the engine I get nothing.  Pressing the start button does nothing at all.  Open battery disconnect, close it back, Medallion screen CPU boots up, press the start button, enter code, press start button again and all is well..... till the next time I stop and float for a while and it's dead again.  Pretty annoying and a little embarrassing honestly that I have to reboot my boat every hour or so to drive it.  I did notice the last time it did this the status of both CAN networks under Diagnostics were offline (No modules communicating) and the status of the "Start/Stop Switch" was "Pressed" which was incorrect but probably wrong because no valid CAN data available.  So I'm thinking the CAN network is dropping out for some reason.  But that doesn't completely make sense because the controls from the Grayhill knob to the radio and Medallion CPU module is all via CAN and that is working when the engine will not start.  All the CAN data to the power modules seems to work also.  The only symptom is no engine start.  Anyway, it is clearly a software bug because the start button works 100% of the time after cycling power to the boat and allowing all the modules to reboot.  Is this happening to anyone else?

I considered that my two issues may be related.  I will probably try the reset feature in the menu which I assume will completely wipe everything and take me back to an as-shipped configuration.  And if that doesn't fix it I'm gonna get the dealer involved because the no-start thing is really too much to just put up with.  

No OTA update is available according to the Software screen so either OTA updates are not working yet or I have the latest software.   Boat was built March 2020.  

I had the same issue last weekend. Happened to me multiple times on the water where I had to reset everything to get the boat to start.

Share this post


Link to post
Jeepman
On 5/28/2020 at 12:27 PM, JBell said:

I had the same issue last weekend. Happened to me multiple times on the water where I had to reset everything to get the boat to start.

I did a factory reset of the entire dash then went out two days last weekend and it did not do this once.  The reset is a PITA because you have to reconfigure everything about the boat but it did seem to fix both of the issues I was having.  I had probably 20 starts after the reset and not once did it act up.  If you have 20 minutes to reset everything then give that a try.  

Share this post


Link to post
Mrmattieb

If Navionics is still being sorted out are there any other recs for a decent navigation app for the new OS? 

Share this post


Link to post
matthewmiller01

Just got Spotify.  I am new to it.  It plays fine when I am connected to WiFi or tethered to my iPhone.  How do I make it download the music to the boat so that it will play even when the boat is not connected (offline)?

Share this post


Link to post
UWSkier
37 minutes ago, matthewmiller01 said:

Just got Spotify.  I am new to it.  It plays fine when I am connected to WiFi or tethered to my iPhone.  How do I make it download the music to the boat so that it will play even when the boat is not connected (offline)?

believe you have to be a paying spotify user to download music for offline listening.

Share this post


Link to post
matthewmiller01
On 6/14/2020 at 7:05 PM, UWSkier said:

believe you have to be a paying spotify user to download music for offline listening.

Well, damn,  I appreciate the response.

Share this post


Link to post
tower210

It took a few tries; but I got pandora loaded; and it works just like a phone without internet; any downloaded playlists are there

Share this post


Link to post
Malibuckeye

I can't for the life of me find Spotify in the App store.  It won't come up with any search.  Anyone got any tips?   

Share this post


Link to post
RocNE
On 7/22/2020 at 2:26 PM, Malibuckeye said:

I can't for the life of me find Spotify in the App store.  It won't come up with any search.  Anyone got any tips?   

Same for me.  I found Pandora and was able to install that and use successfully.  Still would LOVE to get Navionics/Garmin Boating HD loaded for an upcoming trip to the Ozarks!  Obviously can use my phone, but would prefer to have it on the dash.  I would like to try loading the APK files, but I think I'll wait until AFTER my upcoming trip LOL!  If anyone has found any other app or way of loading a decent marine charting app, please let me know!!

Share this post


Link to post
Jmo617
7 hours ago, RocNE said:

Same for me.  I found Pandora and was able to install that and use successfully.  Still would LOVE to get Navionics/Garmin Boating HD loaded for an upcoming trip to the Ozarks!  Obviously can use my phone, but would prefer to have it on the dash.  I would like to try loading the APK files, but I think I'll wait until AFTER my upcoming trip LOL!  If anyone has found any other app or way of loading a decent marine charting app, please let me know!!

I got tired of waiting on the navtronics fix for my Ozark trip. 

14EAF1BF-9308-428D-9D01-3300120B85A9.jpeg

Share this post


Link to post
RocNE
13 hours ago, Jmo617 said:

I got tired of waiting on the navtronics fix for my Ozark trip. 

14EAF1BF-9308-428D-9D01-3300120B85A9.jpeg

Might do the same either using my phone or my Humminbird Helix 7 out of my Lund for now. Have you been able to charge your phone wirelessly using the dash-mounted phone holder/charger?  Mine doesn't seem to charge, but the gunwale-mounted charger works...

Share this post


Link to post
Jmo617
4 hours ago, RocNE said:

Might do the same either using my phone or my Humminbird Helix 7 out of my Lund for now. Have you been able to charge your phone wirelessly using the dash-mounted phone holder/charger?  Mine doesn't seem to charge, but the gunwale-mounted charger works...

@RocNE I tried the phone prior to ordering the garmin but screen size wasn’t workable for me and didn’t want to conflict with the music DJ.  My dash wireless charger seems to work well even with the case on.  Somewhere I think I heard of the wires coming lose on some....

Enjoy your trip. 

Share this post


Link to post
tower210
4 hours ago, Jmo617 said:

@RocNE I tried the phone prior to ordering the garmin but screen size wasn’t workable for me and didn’t want to conflict with the music DJ.  My dash wireless charger seems to work well even with the case on.  Somewhere I think I heard of the wires coming lose on some....

Enjoy your trip. 

This seems like a natural upgrade Malibu could offer; all the hardware is there.  It should be like the Audi display where the speed & rpm are in the corners of the big display; and the map covers most of it for navigation

 

Share this post


Link to post
Weave

Any updates on the Navionics app, or google play store? Just bought a 2021 20VTX and I agree the Navionics app would be a really nice upgrade.

Share this post


Link to post
Gene3x

It would be nice but this tablet seems worthless.... Painfully slow. Maybe good for downloading songs if you have the patience. It would be nice to have an upgrade but I think the processor is to slow or not enough memory to run it properly.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...