Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Service required alarm


Recommended Posts

I bought a 2007 lsv 23 a couple of months ago. It has been running perfectly until last week. Now every time I shift into reverse and then back to forward a service alarm goes off and I lose throttle. When I turn the boat off and back on it resets and throttle works again, until I use reverse. WTH?

Link to comment

It is likely a problem with the PPS (pedal position sensor) or wiring/plug to it.  Many 2007 models have a Throttlemate sensor located on the motor with the throttle cable from the helm attached to it.  See if you have a DTC code stored on your info display with the SPN / FMI numbers to confirm there is a ETC (electric throttle control) trouble code.  It may be as simple as a cable adjustment to fix it, or the Throttlemate sensor may be worn out.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...