Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Budreau

Wetsounds WS-220BT problems

Recommended Posts

Budreau

I just had a new Wetsounds WS-220BT installed by a stereo shop in my hometown in Oregon. It worked great for one weekend. Second weekend out and it worked for a few seconds and then will not connect to Bluetooth and will not play on an aux cord either!?. It lights up so there is confirmed power. Any ideas would be appreciated but I am not too optimistic at this point. I have checked all fuses, breakers, etc. 

Share this post


Link to post
Share on other sites
MLA

Dump the paring from your phone, pull the EQ"s inline fuse, wait a minute, then reinstall fuse and see if your phone see's the BT then repair and try again.

Double check that the AUX cable is plugged into the AUX-in and not the AUX-out and the mode dial is in AUX not main or BT. 

Share this post


Link to post
Share on other sites
Budreau

Thank you. It turns out the brand new unit was “faulty.” It was only two weeks old. I guess I am glad it happened now and not out of warranty. I am a bit skeptical of Wetsounds products at this point. Especially for the cost of the equipment. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...