Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
spinxt

Shower Not working (still)

Recommended Posts

spinxt

Some of you may have read my last post...I removed the mixing valve and found a crack which I repaired with epoxy.  The mixing valve is not the issue.   Pump comes on...I can hear it running, but I’m still only getting dribbles of water.   

Any ideas other than the mixing valve??

Share this post


Link to post
Share on other sites
blk93jeepzj

What type of pump do they use for the shower? 

Possible that the impeller is bad?  Or the pump is not primed?

Share this post


Link to post
Share on other sites
asnowman

There should be screens on the inlets to the mixing valve, similar to a sink or washing machine.  Also make sure you don't have junk clogging the water feeds from the engine, especially the hot water side.  The hot water feed comes out of the block and is prone to clogging. I always run a copper wire up in the block in the fall to clean out the debris that builds up.

Share this post


Link to post
Share on other sites
mikeo

I don't want to bash, but the configuration Malibu used in '15 23 LSV wasn't a good one. I found that the fittings used were metric/european and then adapted with barb fittings via PEX. My shower was sucking so much air that it was almost impossible to get any water out of the sprayer. The fittings on the mixer didn't match the pump and the mixer fittings were tiny compared to any residential plumbing I've seen/used.

I really need to finish the project, but I dumped almost everything that Malibu installed in my boat for the shower except the two fittings that give me hot and cold water. I've changed the pump to a smaller version of the Johnson ballast impeller pumps and I've got a Moen mixer valve and hand sprayer sitting in one of my swim platform storage bins.

Share this post


Link to post
Share on other sites
Dare2goBare
2 hours ago, spinxt said:

The pictures aren't working in the post you referenced above.

Yes I know... Thx. It's only of the T installed into the Raw water feed b4 the Raw water pump. But my synopsis pritty much pins it,

Not sure why the pic won't come up!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...