Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Capdoogie

Surfband leaking inside

Recommended Posts

Capdoogie
Posted (edited)

So, after first time out surfband stop working on new boat.  Thought maybe battery was dead.  Open back battery cover to find condensation slightly wet inside battery area.   Tested battery it was dead but maybe due to wetness.  Has anyone ever opened there’s up? I’m sure it shouldn’t be wet, I would think. Maybe this is why others can’t get there surfband to work right either?

Edited by Capdoogie

Share this post


Link to post
Share on other sites
23LSVOwner

Sounds like the battery cover wasn't on tight so it didn't seal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...