Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
goingboating

Map Sensor Location on 2005 Indmar Monsoon 340 hp

Recommended Posts

goingboating

I have been reading up on issues & resolutions & the map sensor sounds like it maybe my issue.  Running rich, rough idle & today it would crank but not start like no fuel getting to it.  Then it started up after a while.  These are on the symptom list for bad map sensor.  I can’t find the  map sensor to pull off & see how dirty it is.  Anyone have a pic or diagram.  I have never removed the cover because it is connected to the K & N air filter & not sure what else.

Share this post


Link to post
Share on other sites
Woodski

Go to 'Help locating engine components' thread in this section.  See the diagram posted.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...