Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
AussieSkier

Depth gauge stoped working 2018 VTX

Recommended Posts

AussieSkier

My depth gauge on the main screen stopped reading. It now just reads 0 all the time. No different with paddle wheel or GPS and no different on imperial or metric settings. Any tips / hints to rectify other than the obvious taking to our dealer? Thanks

 

Share this post


Link to post
Share on other sites
ahopkinsVTX

I’d start with making sure all connections under the dash are good. I’m not sure where the actual sending unit is but I’d try to locate that too.

Did it just stop working like someone turned a light off or was it giving you periodic problems then it finally quit?

Share this post


Link to post
Share on other sites
AussieSkier

Thanks.

 

Just stopped. Fine one weekend. Next weekend Zero

Share this post


Link to post
Share on other sites
ahopkinsVTX

I mean that could be a bad sensor but I’d think it lost total connection somehow. 

Share this post


Link to post
Share on other sites
JSVLX

Same problem with 2017. Dealer service guy said check connections near sensor under flooring through access by driver seat. With bilge pump and ballast pumps there’s too much clutter to find sensor wiring. I’ll check under dash next 

Share this post


Link to post
Share on other sites
daylorb

Same problem with my 2018 A24.  Stopped working before 10hrs on the boat.  Took it into dealer, they can't figure it out.  They said they swapped everything on the boat, new finder, lcd screen, wires - nothing will make it work.  Bizarre.  Malibu US said it was some kind of software problem with the entire system.  So I have the boat back - no depth finder.  I'm told they are working on a fix, no idea how long I'll be without it.  Thankfully our lake isn't all that shallow, bummer to not have it working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...