Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

LarsJensen

Automatic Bilge Pump won’t turn off

Recommended Posts

LarsJensen

Real quik

put the boat in the water after torrential rains in southern Wisconsin. Tons of water in the ski locker and engine compartment. Emergency bilge kicked on but pump wouldn’t turn off. Had to disconnect battery after getting boat back on trailer to get pump to turn off. I’m sure the float switch just isn’t disengaging. Anyone know where to look?

Share this post


Link to post
Share on other sites
wdr

In the vicinity of the back of the oil pan. Port side on mine, yet it drains out the starboard side. Probably just sucked up a leaf or stick that is keeping the float raised and running. The pump will come off of the base which is glued or screwed to the deck which will expose the float and the crud under it.

Edited by wdr
Sp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...