Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Javi

2006 Graphical In-dash display gone blank.

Recommended Posts

Javi

Has anyone had this happen to them?

My display has turned blank... it happened while driving. It was working fine and then it just turned itself blank. It did that last time I was out, but it started working as soon as I restarted the engine. But not anymore. What you will notice on the picture below is that when the display goes blank, the tachometer's display keeps reading fine but the speedometer display stops showing the depth reading. Air and lake temperatures still show.


Any ideas??

y4mnLXOZ5VgUUPuadHRDTsgF6vgvAzfZUBLT1abF

 

Edited by Javi

Share this post


Link to post
Share on other sites
obaro15

You can try unplugging and plugging it back in.  This extended the life of my display for a season, ultimately it is probably on its way out...

Share this post


Link to post
Share on other sites
Javi

If it in fact is that the electronic display is dying, where do you get a new one? and is it a matter of plug and play?

Share this post


Link to post
Share on other sites
Javi

UPDATE:

For those who may have a similar issue in the future. This is what I did to fix the problem. I removed the three screws of the dash (two on the malibu logo) and one above and pulled it out. I disconnected the wiring and reconnected it shaking it in to get good contact. It seemed to work, but still appeared to have a connectivity issue when moving it around. I went ahead and disconnected the wiring harness clip again, cleaned with a tooth pick with methanol (any alcohol will work), added some dielectric grease (a grade that will not crack the plastics later) and then reconnected it. In fact, since I was at it, I did the same for all the other wiring that goes to the other dials. I did that about a week and a half ago and it has been working fine up to this point.

Share this post


Link to post
Share on other sites
Dodger40

Anyone know where to buy the display if it quits working. Mine still works, but I do wonder if it goes out what I would do. I have looked at Bakes and Great Lakes Skipper, but can’t find them

Share this post


Link to post
Share on other sites
Javi

Same here, I wonder if it would be a good idea to proactively ask Malibu to see where they direct us. I was not able to find it anywhere either.

Share this post


Link to post
Share on other sites
squirter

This has just happened with my 07 Response. Been dropping in and out over the last couple of months, but has completely dropped out now.

Have pulled it out of the boat and will clean the contacts.

My question is, Javi, is your screen all good still.

Share this post


Link to post
Share on other sites
dalt1

Been a long time ago now, but my 06 had dash dropouts and I finally tracked it to the bundle of wires behind the dash that did not latch together tightly. The Plastic bundle connector didn't want to lock together. I put a small zip tie around it pulling both halves tight to each other and and never had a problem again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...