Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

teamerickson

Now That's Service - Larson Marine!

Recommended Posts

edo

What did it do ??

 

Share this post


Link to post
Share on other sites
teamerickson

During the last day, and last rider, after the rider fell throttled down to pickup rider. It wouldn't go into forward. At first we thought we lost prop but reverse worked. Pretty sure it wasn't the neutral lockout, although symptoms seem like lockout. Reset the screens a few times then reset battery switch. We were looking around tranny area didn't see anything. Tried it again at it worked. Headed back to dock. 

Share this post


Link to post
Share on other sites
Agman

:plus1:

Craig and his team always deliver. 

Share this post


Link to post
Share on other sites
Txstoj

We had something similar happen in our 17 T23 last week.  I fell surfing and my driver was turning around, she put the boat in neutral for a few seconds.  When she put it back in gear and gave it throttle, she got no throttle response.  She had to turn the boat off and restart before the throttle arm would work.  Has not happened again but keeping an eye out to see if it does it again.

Share this post


Link to post
Share on other sites
shawndoggy

Ugh. I hate weird stuff like that. Did they diagnose a problem or just shrug and say “seems to work good now”? 

Share this post


Link to post
Share on other sites
teamerickson
1 minute ago, shawndoggy said:

Ugh. I hate weird stuff like that. Did they diagnose a problem or just shrug and say “seems to work good now”? 

They updated software, checked connections and performed some tests. Worked fine. Just made me feel better having them give it the run through. Hopefully it doesn't happen again! The joys of electronic throttle control!

Share this post


Link to post
Share on other sites
Fman

The price we pay for buttery smooth throttle response! Glad they took care of you.  Did he mention what the new software updates corrected or added any new features?   I am due for an update myself.

Share this post


Link to post
Share on other sites
teamerickson
1 minute ago, Fman said:

The price we pay for buttery smooth throttle response! Glad they took care of you.  Did he mention what the new software updates corrected or added any new features?   I am due for an update myself.

I'll try and find out what was in the update. 

Share this post


Link to post
Share on other sites
UWSkier
1 hour ago, Fman said:

The price we pay for buttery smooth throttle response! Glad they took care of you.  Did he mention what the new software updates corrected or added any new features?   I am due for an update myself.

Cables are buttery smooth too.  Curse GM for making us ditch them...

Share this post


Link to post
Share on other sites
isellacuras

I hate those intermittent problems. They are rough on you and the dealer. What makes it bad is you take it in and they say it's working and over the next few trips out, it does it again. 

Do you all update your stuff each time an update comes out?  I tend to lean toward the "if it ain't broke, dont fix it" mind set. 

Share this post


Link to post
Share on other sites
teamerickson

It’s only done it once, so fingers crossed. 

I’ve had my screens lock up a few times so I thought I ‘d update software. 

Share this post


Link to post
Share on other sites
Nitrousbird
21 hours ago, UWSkier said:

Cables are buttery smooth too.  Curse GM for making us ditch them...

Better speed control with drive by wire.  I was disappointed my boat didn't have it.  Placing Corvette fuel rail covers on a LS1 doesn't make it a Corvette motor Indmar...

Share this post


Link to post
Share on other sites
jmack
On ‎8‎/‎3‎/‎2018 at 4:05 PM, Nitrousbird said:

Better speed control with drive by wire.  I was disappointed my boat didn't have it.  Placing Corvette fuel rail covers on a LS1 doesn't make it a Corvette motor Indmar...

Last time I checked, an LS1 was a Corvette motor...

Share this post


Link to post
Share on other sites
Fman
On 8/2/2018 at 9:42 PM, isellacuras said:

I hate those intermittent problems. They are rough on you and the dealer. What makes it bad is you take it in and they say it's working and over the next few trips out, it does it again. 

Do you all update your stuff each time an update comes out?  I tend to lean toward the "if it ain't broke, dont fix it" mind set. 

Same here...I have been pretty much bug free and am really thinking about waiting until I need to.  Unless they have come up with some new added features.

@teamericksondo you keep your batteries on a maintainer all year?  And when your screen locked up was it after a few days on water with no battery plug in charge?  Just curious....

Share this post


Link to post
Share on other sites
Nitrousbird
6 hours ago, jmack said:

Last time I checked, an LS1 was a Corvette motor...

Also the motor put in the 98-02 Camaro and Firebird, along with the 2004 GTO, among other vehicles outside the US.  It is not a Corvette exclusive motor. 

What is different is those cars mentioned above did not have drive by wire when the Corvette did.  The Indmar LS1 has more in common with the other vehicles than the Corvette...

Share this post


Link to post
Share on other sites
teamerickson
14 hours ago, Fman said:

Same here...I have been pretty much bug free and am really thinking about waiting until I need to.  Unless they have come up with some new added features.

@teamericksondo you keep your batteries on a maintainer all year?  And when your screen locked up was it after a few days on water with no battery plug in charge?  Just curious....

Don’t think it’s the batteries. One time charged all night. Turned it on before heading to ramp from home. 10 minute drive. Start button would not work. Had to turn off batteries. Another time it locked up while pulling a rider and adjusting music. It only happened a few times. Hopefully the update will help. 

Share this post


Link to post
Share on other sites
FatGoldChain

Shot out to a dealer taking care of their customers!

So far Larson has taken great care of me!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...