Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

MALSI

Cyl 7 misfire

Recommended Posts

MALSI

Hey Malibu Crew!

so here’s a long winded history of my issue. I have a 07 Malibu wakesetter 20 vtx with 179hrs. I take the boat out 4-5 times for a couple hours each time with no problems, on the last time i get a service eng code with multiple Cyl misfires. Now the misfire is consistently on Cyl 7 only now.  

I have replaced:

1. spark plugs with recommended ac Delco (the previous plugs were still in good condition), wires(previous ones were indmar), distributor cap(previous cap had build up on the points)  and rotor  

2. Removed almost all of the gasoline (also added water remover in tank incase I didn’t get ever last drop)

3. Changed the gas filter Catridge that seemed to have evidence of water in it.

4. Have switched the injectors around with other cylinders

5. Compression tested Cyl 3,5&7 all have 150 psi (cold engine)

So Cyl 7 plug arreared to be fouled so I replaced it and switched the injectors around and now I can get to about 30 mph and then codes appear and engine seems to go into limp mode. If I cycle the key off and on, it will do the same thing. 

On idle it runs great.  If I idle at high rpms still no problems.  Problem only occurs under load!

Any suggestions???

thx 

 

 

Share this post


Link to post
Share on other sites
oldjeep

Has the cam angle been checked? (timing)  Diacom will be able to show freeze frame data from when the code set. 

Share this post


Link to post
Share on other sites
justgary

Bent pushrod, maybe?  It might be worth pulling the valve cover to make sure everything on top of that cylinder works the same as the others. 

Share this post


Link to post
Share on other sites
MALSI
14 hours ago, oldjeep said:

Has the cam angle been checked? (timing)  Diacom will be able to show freeze frame data from when the code set. 

Haven’t checked timing as it idles fine and Runs good until it goes into limp mode 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...