Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Scott1969

2017 VLX with major glitches

Recommended Posts

Scott1969

We have had the boat for a little over a year with no issues. These are the issues that started last weekend:

- The first issue was the surf gate getting stuck out. After powering the boat down and back on it came back in.

- Blower will not come on. Touch screen says its on.

- Left rear hard tank pump will pump water in regardless of it being selected on the touch screen or not. It will run with only the battery being turned on and dash/ boat off. Pulled fuse to stop this.

- Boat will run long after you have pushed the button to cut it off

- Running lights are on but touch screen shows they are not on.

- Stereo will not power up.

- High pitched screeching feedback through the speaks when you put the boat in forward or reverse and will happen randomly when boat is on. As I mentioned the stereo will not come on.

- Touch screens dims when the boat is put in forward or reverse.

- Tried the factory reset a few times with no luck.

-Discussed with  the repair manager at my Malibu dealer. He had a few suggestions but no luck. He seems to think its a software issue.

I'm sure there are more issues but put it up with all the above going on. Any ideas?

 

 

 

-  

 

Share this post


Link to post
Share on other sites
teamerickson

Sorry to hear this. 

How are the batteries?

Share this post


Link to post
Share on other sites
wbama387

I would check the batteries. Also make sure you are not charging your phone through the the usb at the drivers helm. I have had some of these issues show up when I was trying to charge my phone there. If it is not either of those I would try the new version of the software. Somewhere in the settings it list a website where you can download the software on a usb and load it on the boat.

Share this post


Link to post
Share on other sites
Scott1969

Batteries seem to be fully charged. No issues starting.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...