Jump to content
Pkcoyle

Warning- auto bilge

Recommended Posts

Pkcoyle

I am a first time boat owner.  When I filled all ballasts.... back, center, and front while surfing for about 30 min, the bilge warning came on.  A large amount of water was in the bottom of the boat.   Is this normal while surfing or is there a possible leak in one of the ballasts?

Share this post


Link to post
Share on other sites
jwl019

On mobile so I can't see what year model you have, but could be from how fast you slow down to pick up a downed rider and water coming in the vents on the back corners?  As long as it pumps out and shuts off, you should be fine if it is coming from the vents.

Share this post


Link to post
Share on other sites
Pkcoyle

I have a 2014 lsv.  Was driving at about 10 mph.   Thanks for the comments.  

Share this post


Link to post
Share on other sites
Heiny

I would check the connections to your bags. I have one bag fitting that keeps coming off one of my rear bags. This has happened to a couple of my other friends with Malibus too. The tube is too short so when the bag fills it pulls away from the fitting. I had to adjust how my bag sits.

Share this post


Link to post
Share on other sites
JeffC
2 hours ago, Heiny said:

I would check the connections to your bags. I have one bag fitting that keeps coming off one of my rear bags. This has happened to a couple of my other friends with Malibus too. The tube is too short so when the bag fills it pulls away from the fitting. I had to adjust how my bag sits.

I had the same issue... starboard side bag connection was coming loose.   Adjusted and didnt have the problem again.   

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×