Jump to content
Steve B.

Alarm on constant

Recommended Posts

Steve B.

Ugh, issues. 02, 325 monsoon. Just changed brass fittings at oil pressure unit. No Teflon tape or anything. Also changed fuel pump. I tried removing wire from switch while running. Alarm always on. Pressure looks good, temp looks good. Batteries charged. Again, all help is very much appreciated. So frustrated right now. Is the switch just standard like any v8 chevy !

Steve B.

Edited by Steve B.
Added info

Share this post


Link to post
Share on other sites
formulaben

BEEP CODES — the 4 maintenance items that can trigger the beeper are:

  • High engine water temperature (>203*)
  • Low oil pressure (<6 PSI) at switch to ECM
  • High transmission temperature (>140?*)
  • A diagnostics trouble code

 

2a4zles.jpg

2r289lk.jpg

Share this post


Link to post
Share on other sites
LowProfile

Following 

Share this post


Link to post
Share on other sites
Steve B.

Thanks in advance, again for all help. I've removed the connector from the oil pressure switch while running, alarm still sounds. Can I rule that out as a possible suspect ? My connections at tranny and water temp look good. This happened after I replaced brass fittings at oil pressure sending unit. Help !  Ha.

Steve B.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×