Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Weaklink

Rear port locker won’t drain-dealer can’t figure it out

Recommended Posts

Weaklink

Pics here https://imgur.com/a/tj5ZcW5

dealer says subfloor has to come out which means lost days on the lake. I’ve tried a wet vac which cleared the water and the dealer asked if I had tried a coat hanger so I’m guessing they tried that? I can get a finger in there and it feels clear. The hole shrinks down further back. Anyone have any experience with this? 

Share this post


Link to post
Share on other sites
oldjeep

I'd definitely try to snake it out with sometbing flexible. Could just be a dead mouse 😱   Alternately try shooting some compressed air through it and see what happens

Edited by oldjeep

Share this post


Link to post
Share on other sites
DockRocketeer
2 hours ago, Weaklink said:

Pics here https://imgur.com/a/tj5ZcW5

dealer says subfloor has to come out which means lost days on the lake. I’ve tried a wet vac which cleared the water and the dealer asked if I had tried a coat hanger so I’m guessing they tried that? I can get a finger in there and it feels clear. The hole shrinks down further back. Anyone have any experience with this? 

as in subfloor that sits over top of the fuel tank?  On the other side of that drain is a hose that leads into the stringer which eventually leads to the bilge.  Possible that the hose is kinked or maybe got plugged....

Share this post


Link to post
Share on other sites
Weaklink
On 6/27/2018 at 3:40 PM, DockRocketeer said:

as in subfloor that sits over top of the fuel tank?  On the other side of that drain is a hose that leads into the stringer which eventually leads to the bilge.  Possible that the hose is kinked or maybe got plugged....

As in the ballet tanks etc come out. He mentioned that the hose may be kinked. By what?

Share this post


Link to post
Share on other sites
Weaklink
On 6/27/2018 at 3:27 PM, 23LSVOwner said:

What boat?

21vlx

Share this post


Link to post
Share on other sites
23LSVOwner
7 hours ago, Weaklink said:

21vlx

Year?

 

7 hours ago, Weaklink said:

As in the ballet tanks etc come out. He mentioned that the hose may be kinked. By what?

Expanding flotation foam.

Share this post


Link to post
Share on other sites
Weaklink

so...no easy fix? I guess I'll deal with the water until fall.

Share this post


Link to post
Share on other sites
Blenderhead

My 2018 21 VLX does exactly the same thing.  According to the dealer it is a known flaw during the build process where the drain hose is crushed by the ballast hard tank.   In order to fix they would have to do extensive work that would put your boat out of commission for at least a couple weekends.  My dealer mentioned a quick fix that involved just drilling straight down to drain into the hull however there is a risk of puncturing the hard tank.....  I opted to not do that.  Will wait till the off season.

Share this post


Link to post
Share on other sites
Weaklink

Me too. But looked in there the other day and it was dry. Weird.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...