Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Bawbe B

03 Xti electrical issues

Recommended Posts

Bawbe B

Electrical gurus.. I am chasing down a few wiring gremlins on my Xti.

#1 No Nav lights. All breakers are good.

#2 rear heater blows breaker on high, but not on low. Have power through switch on low, but the fan isn't kicking in. No lights on switch when in the on position.

#3 shower switch has 12volts coming in, but only 9volts going out when switched on. Light on switch doesn't come on. Pump doesn't kick in.

Any ideas?

Thx

Edited by Bawbe B

Share this post


Link to post
Share on other sites
minnmarker

You probably have a few  bad switches. Try everything after removing the wire ends from the switches and contacting them by hand.  My nav lights had the same problem and a new switch cured it.

Share this post


Link to post
Share on other sites
Bawbe B

Thanks.. appreciate it

Share this post


Link to post
Share on other sites
formulaben

#1 No Nav lights. All breakers are good.

Are you getting power at the Nav light sockets?

#2 rear heater blows breaker on high, but not on low. Have power through switch on low, but the fan isn't kicking in. No lights on switch when in the on position.

No lights on switch is probably the ground on the switch; it usually is only for the light.  It should be the wire at the top of the switch, just check it hasn't worked its way out.

#3 shower switch has 12volts coming in, but only 9volts going out when switched on. Light on switch doesn't come on. Pump doesn't kick in.

My guess is bad switch, but even with only 9 volts the pump should do something.  Again, the light on switch is from the ground at the ground at the back of the switch, and it is there only for the light.  I would remove the switch panel and check ALL connections on the back of the switches.

You might find this helpful, assuming you have the same switches as me:

https://www.dropbox.com/s/5hlljqk3q4k2weh/Contura switches guide SUMMARIZED Contura IV.pdf?dl=0

Share this post


Link to post
Share on other sites
formulaben

Go ahead and download it, it's on my dropbox but could disappear someday when I'm clearing space.  Carling has this online I was just too lazy to find that link.  It has come in VERY handy when adding/replacing switches.  When you dig in there it becomes impressive how much a simple ON-OFF-ON switch can control, especially when you're doing the wiring!

Share this post


Link to post
Share on other sites
minnmarker
1 hour ago, formulaben said:

Go ahead and download it, it's on my dropbox but could disappear someday when I'm clearing space.

Done, thanks.

Share this post


Link to post
Share on other sites
Bawbe B
7 hours ago, formulaben said:

#1 No Nav lights. All breakers are good.

Are you getting power at the Nav light sockets?

#2 rear heater blows breaker on high, but not on low. Have power through switch on low, but the fan isn't kicking in. No lights on switch when in the on position.

No lights on switch is probably the ground on the switch; it usually is only for the light.  It should be the wire at the top of the switch, just check it hasn't worked its way out.

#3 shower switch has 12volts coming in, but only 9volts going out when switched on. Light on switch doesn't come on. Pump doesn't kick in.

My guess is bad switch, but even with only 9 volts the pump should do something.  Again, the light on switch is from the ground at the ground at the back of the switch, and it is there only for the light.  I would remove the switch panel and check ALL connections on the back of the switches.

You might find this helpful, assuming you have the same switches as me:

https://www.dropbox.com/s/5hlljqk3q4k2weh/Contura switches guide SUMMARIZED Contura IV.pdf?dl=0

Thank you very much for the info. When I get to the lake this weekend I'll do more probing. The download was very interesting. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...