Jump to content
707wakesurfer

Bilge switch short?

Recommended Posts

707wakesurfer

This is a new one for me and this boat. When I turn the ignition key one click to the right (as if to start the boat) the bulge pump comes on and the bulge pump switch is off. If I turn on the bilge switch with the key off, the computer begins its pre-start routine. Everything worked fine when I put the boat away last fall. I replaced the bilge pump figuring it went bad but that’s not the problem. Any suggestions on which switch to tackle?

Share this post


Link to post
Share on other sites
Imedrano

I am pretty sure that I am mis-reading your post, but did you by chance accidentally swap the constant hot wire with the wire that goes directly to the switch on the dash? 

Share this post


Link to post
Share on other sites
707wakesurfer

Nope!  Nothing was changed from when I put the boat away after last summer.  I’m afraid I’m going to have to just go through each wire. There must be a short somewhere behind the dash?

Share this post


Link to post
Share on other sites
Imedrano

When you turn the key to the left in order to turn on the accessory panels, and you turn on any of the other accessories, do any of them cause the computer to start its pre-start sequence? 

Share this post


Link to post
Share on other sites
707wakesurfer

Nope. Only the bilge switch. In fact the key doesn’t have to be on and if I push the bilge switch to on the pre-start sequence starts. Has to be a ground. I need to find where the bilge ground wire is connected 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×