Jump to content
Sign in to follow this  
9452772

Broke oil sending unit mounting tube

Recommended Posts

9452772

OK, I have a 2003 Monsoon 340.  I went to remove the oil pressure sending unit and the "tee" tube that connects to the engine and supports the sending unit and oil switch broke from the nut that holds the tube in the engine.  See picture below.  Question is, where do I get another assembly?  Is there a sequence to install new oil feed tube and tee, sensor and switch?  Also, how do I remove the switch?  The sending unit has a obvious nut that was easy to remove the sending unit but the switch is not as easy. 

 

Thanks for all the help so far.

 

http://oil_zpsivtgtvek.jpg

Share this post


Link to post
Share on other sites
MadMan

You can get that broken pipe from Lowes, Home Depot, etc.

The switch housing does have "flats" on it that socket or box end wrench fits.

Share this post


Link to post
Share on other sites
9452772

Thanks for the info.  After having a cold one I got it all separated and will head to the hardware store in the morning.

Share this post


Link to post
Share on other sites
MadMan

Both these sending units are infamous for failing, you might want to go ahead and replace them both.

Also, when you assemble it, don't use Teflon tape on any fitting,  both of those senders require a ground path through the threads.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×