Jump to content
Lakelife

VLX Issue

Recommended Posts

Lakelife

We have a 2008 Wakesetter VLX and had the front ballast tank pump go out.   Mechanic replaced it and now the front tank does not show up on the screen.  Screen is blank where the front tank was?  Any help appreciated

Share this post


Link to post
Share on other sites
Fman

Assuming you have Maliview?  Is there an option in maliview to add the bow tank?  I think there is but its been a few years since I used maliview.  I know you could order that boat with no bow tank which leads me to recall the front tank needs to be enabled in maliview.  If you have your manual handy check that for directions.  Its probably in a settings menu somewhere. 

Also check to make sure wire is connected for tank float.  Pull up your cushions pull up sub floor panel and it will expose the tank to inspect wire.

Edited by Fman

Share this post


Link to post
Share on other sites
csleaver

The info center display will only show ballast tanks that have ballast tank senders connected to it.  If one of the tank senders is open or disconnected, or if any one of the four circuits from the MINI MMDC plug to the sender then to the ground buss is open, then it will not display the tank level.  The MMDC is looking for 33-240 ohms resistance on each circuit to determine if the tank is there.  I would check the helm ground buss connections first, then the sending unit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×