Jump to content
DrFred

Boat won't always start.

Recommended Posts

DrFred

2013 VTx with maliview.  Engine is normally started by entering a code and pressing start engine.  It never worked well in bright sunlight and i now it takes 10 to 15+ attempts of hitting the start engine symbol then it suddenly fires up right away.  Today it was overcast, we didn't dare shut the boat off and once back on the lift it wouldn't re start. I tried using a key to start it but it also seems to be locked out.  Any ideas?  Firmware update, etc?

Share this post


Link to post
Share on other sites
Fman

The keyed back up should over ride everything and start up boat.  Are you sure the boat was in nuetral and safety lanyard was not accidentally engaged?  At first I was thinking your screen might be toast, but not having the keyed back up working leads me to suspect something else.  You could definitely do a software update as well.

When pressing start icon on touch screen is the engine actually turning over at all or nothing happens?

Share this post


Link to post
Share on other sites
DrFred

Nothing happens.  Then after waiting, trying several more times, it fires right up.

Share this post


Link to post
Share on other sites
wdr

Ever drown the starter.

Share this post


Link to post
Share on other sites
csleaver

It could be loose connections on the starter or battery.  Maybe check the starter relay by swapping it with the fuel pump relay.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×