Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

2000 Sportster LX oil pressure gauge not working


Recommended Posts

My oil pressure gauge is not work. All other gauges in the cluster are working properly. Does anybody have any suggestions on how to fix this problem? 

Thanks in advance

Link to post

iirc you should not use teflon tape sealer on the oil pressure gauge as it interferes w the electrical signal.

i could be wrong here - a search on site may be worthwhile.

my (injected) engine has two senders.  one is a one wire while the other is a two wire.  

        i'd be tempted to run sealer / teflon if yours is a two wire unit.  if yours is a one wire unit i'd look at trying w/o teflon tape.

  • Like 3
Link to post

Ok so I replaced the oil pressure sending unit and gauge is still not functional. Anybody have any other ideas. I checked the gauge and it only has one connection. My gauge cluster is medallion instrumentations systems. This particular gauge part number is 6703-00005-01 if anyone knows where I can get a new one. Thanks for the help 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...