Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
kx250frider617

Finally finished up the stereo!

Recommended Posts

kx250frider617

Well it took a couple years to finally peice together my stereo for my 12' axis a22. The last project was a new amp for the cabin speakers and sub. 

I added the Rockford Punch 1000x5 and completed the amp rack with a nice little cover to hide the wiring. 

 

E415F7BC-06AD-4B6D-8340-8BE94C99883B_zps

All my components include the stock Sony HU, Rockford power T1000-4 for the towers powering 4 Skylon vector 8 HLCD speakers. The cabin I have the Rockford Punch P1000x5 powering 6 of the new Punch 6.5" marine speakers and a 12" alpine type r sub. 

 

I know it's not the most extravagant stereo system, but it is LOUD and has great sound quality. 

Edited by kx250frider617

Share this post


Link to post
jbcanski2

Congrats! Enjoy it!

Share this post


Link to post
skylerchamblee
On 1/16/2017 at 6:17 PM, kx250frider617 said:

Well it took a couple years to finally peice together my stereo for my 12' axis a22. The last project was a new amp for the cabin speakers and sub. 

I added the Rockford Punch 1000x5 and completed the amp rack with a nice little cover to hide the wiring. 

 

E415F7BC-06AD-4B6D-8340-8BE94C99883B_zps

All my components include the stock Sony HU, Rockford power T1000-4 for the towers powering 4 Skylon vector 8 HLCD speakers. The cabin I have the Rockford Punch P1000x5 powering 6 of the new Punch 6.5" marine speakers and a 12" alpine type r sub. 

 

I know it's not the most extravagant stereo system, but it is LOUD and has great sound quality. 

Where did you get the p1000-5? I'm assuming you have the inboats bridged? I need to update our inboats. But would like to do the p1k and speakers. 

Share this post


Link to post
kx250frider617

I got the punch amp from a local audio shop. I have the rear cabin speakers bridged on 3/4 and the front bow on 1/2 and a single 12" sub on the sub channel.

Share this post


Link to post
That Guy

Looks like a clean install, any more pics?

Share this post


Link to post
minnmarker

Cover is a great idea. May copy that.

Share this post


Link to post
MattyICE15
28 minutes ago, That Guy said:

Looks like a clean install, any more pics?

+ 1... show us more! Looks a lot cleaner than my current setup that's forsure 

Share this post


Link to post
Steve B.

I've got the punch 6.5's in the cabin and the 8's on the tower. All in stereo, left side of the boat, right side of the boat.

I'm used to good audio, these things are amazing.

Steve B.

Share this post


Link to post
kx250frider617

I don't have any pics during install but here are a couple.

This is my sub box setup I made. Its a little over 1 cu. ft interior space and is fully resined and siliconed to the plastic foot well to look completely factory. 

image-7_zps624ca6d1.jpeg

Heres what I did for the existing speaker wire holes in the tower. I had to move the inner to speakers towards the center of the tower to allow them to fit. The lights are the same ones used on the LED runway lighting on the trailer, wired to the nav light.

 

C2D789B0-DA2B-4F40-AEE7-7755F3CFBD76_zps

 

And the finished product of the tower. What you can't see is the 4 runs of 12 awg speaker wire running through the tower. That was the real PIA, but I got it done some how.

 

01CDE529-C0EB-4944-9BD4-B5230B0B8061_zps

 

 

 

I also ran all new RCA's, and power/ ground wires for the head unit. I think the only thing left to do is replace the sub with a 2ohm DVC setup to get the full potential of my amp. Right now I have a type R 12" at 2ohm. 

Share this post


Link to post
Steve B.

Your whole rig looks off the hook !  I'm sure it sounds awesome too !

Steve B.

Share this post


Link to post
skylerchamblee

Nice setups..... now here would be my luck. Every thing just right sounding right looks darn good. Launch boat get out of no wake zone and get turnt up and buzzing out of the speakers. Now that's my luck. 

 

 

Congrats on a good build(s)

Share this post


Link to post
kx250frider617
2 hours ago, skylerchamblee said:

Nice setups..... now here would be my luck. Every thing just right sounding right looks darn good. Launch boat get out of no wake zone and get turnt up and buzzing out of the speakers. Now that's my luck. 

 

 

Congrats on a good build(s)

I had the same problem at first. Just run a new power and ground wire straight from your amp dist. Blocks to your head unit. It's a simple fix. The problem is caused by a ground loop through your rca cables. 

 

I used 12g speaker wire to wire mine.  

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...