Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
lakeboy

Fuel pump not priming

Recommended Posts

lakeboy

Fuel pump issues!   I have been changing out many parts on my 99 Malibu Sunsetter with 5.7L.  New plugs, plug wires, PCV valve, distributor cap & rotor, fuel filters.  I turned the key a few times to engage the fuel pump, which it did, then tried to start it but it would not. Then, the fuel pump did not kick in.  The gas shutoff valve was turned off.  Still no sound on the fuel pump.  I checked the 15a fuse for the fuel pump & tried unhooking the battery hoping for a reset.  Could I have burned out the fuel pump or is there something else like a relay switch to look for?  Thanks!  

Edited by lakeboy

Share this post


Link to post
tvano

there are 3 relays mounted near the ecm and they are all alike.

ign, fuel pump and starter.  fuel pump has a green wire in the mix.

swap out fuel pump relay with starter relay (has yellow wire) and see if your problem moves.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...