Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
roeboat

ECU?

Recommended Posts

roeboat

I was on the lake today after pulling two barefooters and a slalomer the LCD screen was flashing ECU. I shut down the engine and opened the hood. Everything looked ok. I started it again and the LCD wasn't flashing anymore. Does anyone know what the ECU is and what the problem was.

Share this post


Link to post
RTS

ECU is Engine Control Unit....the engine's 'computer'.  If it went away and doesn't happen again, I would chalk it up to just an electrical gremlin.  If it continues to happen, I would get my checkbook ready.

 

Share this post


Link to post
Sixball

Some of the older ECU's  are getting hard to find. Like RTS said I hope the restart ( Reboot for the ECU ) is a fix. If not you could try removing the positive cable from the battery that will defiantly do a reboot. Leave it off for  five minutes.  

Share this post


Link to post
Wayne

What year and model boat? On some years when the dash lost communication with the engine control unit the display would just say "ECU". Others actually say "Lost Communication with ECU". Some cases it's just a glitch, some times a connector is flakey and other times the display is going bad. I had the digital display go bad on my 2009 Response LXI the year after we bought it. The display was saying "Lost Communication" about every 3rd start then died. Luckily it was under warranty. On my 2002 Sunsetter the Gage's would go dead on occasion and traced it to a loose connection. 

Share this post


Link to post
roeboat

We have a 2005 Malibu Response LXI

Share this post


Link to post
electricjohn

There is one wire that runs from the ECU  (electronic control unit),  that turns on the hour meter on your dash with a 5 volt signal.  If the dash see's RPM's for the tach and no signal for the hour meter it displays "ECU".  Perhaps nothing more than a poor connection in your engine to dash cannon plug.  You can not reboot a 2005 ECU, but you can have a dealer rewrite to it.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...