Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
teamerickson

New 2017 Wetsounds Factory System

Recommended Posts

teamerickson

I'm looking for feedback on the new wetsounds system Malibu is offering. It seems pretty nice or maybe sales fluff? Anybody hear one? It's kind of a huge deciding factor for me right now. Thanks.

Share this post


Link to post
SmoothWaterMan

Very nice.  Order it.  See other 2017 stereo thread.

Share this post


Link to post
Lees23

I am currently looking for it... :(

Share this post


Link to post
teamerickson
7 minutes ago, Lees23 said:

I am currently looking for it... :(

 

Share this post


Link to post
jonyb

To be quite honest, I'm sure that the factory cuts corners on amplifiers.  All boats I've seen including tritoons, powerboats, and wakeboats, have been weak.  Look into upgrading amps.....

Share this post


Link to post
teamerickson
8 hours ago, jonyb said:

To be quite honest, I'm sure that the factory cuts corners on amplifiers.  All boats I've seen including tritoons, powerboats, and wakeboats, have been weak.  Look into upgrading amps.....

Not this time! These are good amps.

Share this post


Link to post
Fman
Just now, teamerickson said:

Not this time! These are good amps.

Can you actually adjust them or are they totally digital and pre set from WS?

Share this post


Link to post
Lees23
Just now, Fman said:

Can you actually adjust them or are they totally digital and pre set from WS?

I believe they are pretty much locked up.  I haven't looked at mine that closely though. 

Share this post


Link to post
teamerickson
10 minutes ago, Fman said:

Can you actually adjust them or are they totally digital and pre set from WS?

They're digitally preset by wetsounds. I talked to a few audio dealers at the boat show and they said they could adjust them. So, it sounds like they are adjustable but I don't have the hardware to do it.

Share this post


Link to post
David

The factory system is tuned according to a Wetsounds prescription and they know the boat and their own product very well. I doubt you would accomplish much by retuning the system unless you decide to supplement the system. In that case, there are Wetsounds after-market dealers who have been doing this type of DSP product. Actually setting systems up with software and laptops using DSP processors and DSP amplifiers has become mainstream. Wetsounds. JL Audio. Audison. Kicker. Arc Audio. Alpine. Sony. Mosconi. Countless more. And more to come. It's not the future. It's here. Now.  

Share this post


Link to post
MLA

Remember back when TVs had a flip open panel that exposed all the dials to adjust picture, color, etc? Now new generation TVs still have all the settings, but they accessible through the remote using a menu. Same with these amps. Nothing is locked, you just need the proper interface and program. We have one member here already that has re-purposed an OEM installed DSP amp from 4 chnl stereo in-boat duty to bridged 2 chnl tower speaker duty. This was some weeks ago. This shows these are not locked, you just tune them in a different manor then before.   

Share this post


Link to post
Lees23
Just now, MLA said:

Remember back when TVs had a flip open panel that exposed all the dials to adjust picture, color, etc? Now new generation TVs still have all the settings, but they accessible through the remote using a menu. Same with these amps. Nothing is locked, you just need the proper interface and program. We have one member here already that has re-purposed an OEM installed DSP amp from 4 chnl stereo in-boat duty to bridged 2 chnl tower speaker duty. This was some weeks ago. This shows these are not locked, you just tune them in a different manor then before.   

Locked out as far as the average consumer is concerned. 

I just want the drop out issue resolved.  I find it interesting that the wetsounds reps haven't had anything to say about it yet.

Share this post


Link to post
MalibuNation

@Lees23,

Have you called WS directly?  I'm sure that is the best way to contact them and get tech support.  This applies to the other stereo vendors too.

Share this post


Link to post
Lees23

I hope that they would be working with Malibu to figure the issue out.  From all I read, they are aware of the issue but there is currently no fix.  It's not a huge issue, I just hope it gets resolved in a reasonable amount of time. 

I have notified my dealer but will reach out to WS directly as well. 

 

Share this post


Link to post
Lees23

I will have my boat on the water for the first time tonight so I will figure out how much of an issue it really is. 

Share this post


Link to post
Ronnie

Did someone tell you it's a Wetsounds problem and not a Black Box/Viper problem.

Share this post


Link to post
Fman

It makes sense to have digital amps for a package system.   I am sure Malibu ran into problems with customers tweaking there systems and even damaging speakers.  Kind of a set it and forget it.  It will be interesting to see how the new amps perform for everyone.

Share this post


Link to post
MLA
4 hours ago, Lees23 said:

I have notified my dealer

On a current model boat, id doing more than notifying my boat dealer. They should be running point on this for you. They should be your advocate to malibu on this. It should not be up to you to go out and get the fix. lets say this was an engine issue, would you be waiting for indmar to post up here on TMC with a fix? no, id be on my dealer to be on Malibu to be on Indmar. Same with Viper helm system issue. 

Share this post


Link to post
Lees23
1 hour ago, MLA said:

On a current model boat, id doing more than notifying my boat dealer. They should be running point on this for you. They should be your advocate to malibu on this. It should not be up to you to go out and get the fix. lets say this was an engine issue, would you be waiting for indmar to post up here on TMC with a fix? no, id be on my dealer to be on Malibu to be on Indmar. Same with Viper helm system issue. 

I couldn't agree more but didn't want to upset anyone by telling them otherwise.  That being said, I had the boat on the water today and actually useable volume levels it's a non issue. I am not worried about it. 

Share this post


Link to post
jonyb
13 hours ago, teamerickson said:

Not this time! These are good amps.

Then which amps are they?  Htx? Syndx?  SINISTER?

 

 

Share this post


Link to post
teamerickson
5 minutes ago, jonyb said:

Then which amps are they?  Htx? Syndx?  SINISTER?

 

 

Syn-DX.

 

Share this post


Link to post
Lees23

Noticed today while playing around trying to figure out my water leak that the port cabin speakers are about 1/8 as loud as the starboard speakers.  So I stuck my head by all my speakers and figured out that one of the bow speakers is totally silent.  I manipulated the wiring harness with the speaker wires and my port speakers came alive with the appropriate volume.  No change in the silent bow speaker.  I pulled it out to check the connection, which was fine.

I hope I get these issues resolved soon. 

Share this post


Link to post
Fman
1 hour ago, Lees23 said:

Noticed today while playing around trying to figure out my water leak that the port cabin speakers are about 1/8 as loud as the starboard speakers.  So I stuck my head by all my speakers and figured out that one of the bow speakers is totally silent.  I manipulated the wiring harness with the speaker wires and my port speakers came alive with the appropriate volume.  No change in the silent bow speaker.  I pulled it out to check the connection, which was fine.

I hope I get these issues resolved soon. 

Might want to pop out the bow speaker and see if it is even connected.  Or maybe you already did this?

Share this post


Link to post
Lees23
11 hours ago, Lees23 said:

Noticed today while playing around trying to figure out my water leak that the port cabin speakers are about 1/8 as loud as the starboard speakers.  So I stuck my head by all my speakers and figured out that one of the bow speakers is totally silent.  I manipulated the wiring harness with the speaker wires and my port speakers came alive with the appropriate volume.  No change in the silent bow speaker.  I pulled it out to check the connection, which was fine.

I hope I get these issues resolved soon. 

 

9 hours ago, Fman said:

Might want to pop out the bow speaker and see if it is even connected.  Or maybe you already did this?

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...