Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
PurpleHaze

2015 MXZ stalling issues.

Recommended Posts

PurpleHaze

Starting to wonder if I have a lemon on my hands. Have a 22' MXZ with 410 hp motor. I've already had 3 ECMs replaced, the malivue dash and 7" touch screen replaced. My latest ailment has been 2 fold, the master relay keeps tripping and 'loss of can signal' pops up on the screen. I have to pop the engine tray out and reset that little button on the relay and it'll fire right back up. It happens when towing and when underway at mid level RPMs. Now motor is stalling out and not tripping the can signal warning. It seems like fuel restriction issue, but not sure where to start the diagnosis. I've checked all the connections to see if there's any melting/arcing, no evidence of such. Bad fuel filters already? Bad fuel pump? Anyone else having a nightmare with their 2015s?

Share this post


Link to post
Fman

180 hours on my 22 VLX w/409 and has never missed a beat.  It sounds like your dealer and Indmar are replacing components?

Share this post


Link to post
PurpleHaze

I am at 160 hours. After this week's trip to the shop I will have lost 7 weeks on the water in the 56 weeks I've owned the boat. I'm in northern IL so my season is 4 months long. Dealer has been doing all the work under warranty, at this rate I don't want to touch anything for fear of Malibu/Indmar will try to jam me on warranty (Audi did that to me on a car). Was curious if anyone has had the laundry list of issues I have had. Glad to hear you haven't missed a beat.

Share this post


Link to post
Fman

Pretty confident you are not the normal Malibu ownership experience.  I'm on my third Malibu (2011,13,15) and all of my boats have been relatively headache free and reliable.  They are definitely not perfect, I have had two warranty claims on my 2015, a tower strut replaced and two rear seats had new skins put on.  Other than those two items boat has been solid, no glitches or issues.

Hopefully your dealer can get things fixed up for you, it sounds like they are trying to get it corrected.

Share this post


Link to post
23LSVOwner

Sounds to me like it needs a new engine harness.

Your dealer did check over the grounds on the engine, correct?

Share this post


Link to post
JasonK

Sounds like a lemon to me. Off it before it's too late.

Share this post


Link to post
PurpleHaze

I'm pretty sure I just have a one-off situation. This is my first Malibu, but have had 4 other Malibus in the immediate family in the last 20 years. Dealer has stated that they've tested all of the typical suspected bad grounds & bad connectors and everything has tested out OK and they are of the mindset that this latest issue is a fuel obstruction. It would make sense with the engine cutoff and occasional sputter, except that shouldn't trip the Master Relay & trigger a loss of CAN. I would agree that a dirty ground or a bad wiring harness is the culprit.

Share this post


Link to post
PurpleHaze

So dealer just called back, had tech on the boat this afternoon and diagnosed it as a bad engine harness. Fingers crossed that this will the last shop trip until winter layup.

Share this post


Link to post
PurpleHaze
On ‎8‎/‎8‎/‎2016 at 7:10 AM, 23LSVOwner said:

Sounds to me like it needs a new engine harness.

Your dealer did check over the grounds on the engine, correct?

23LSVOwner with a solid diagnosis from afar. New engine harness and new fuse block and I am back in action. Turns out the bad harness caused some internal damage to the relays & fuses on that fuse block located in the engine compartment. Fingers crossed that this will be the end of the gremlins on this boat. I would suggest anyone with early model 2015s to keep an eye on this.

Share this post


Link to post
23LSVOwner
47 minutes ago, PurpleHaze said:

23LSVOwner with a solid diagnosis from afar. New engine harness and new fuse block and I am back in action. Turns out the bad harness caused some internal damage to the relays & fuses on that fuse block located in the engine compartment. Fingers crossed that this will be the end of the gremlins on this boat. I would suggest anyone with early model 2015s to keep an eye on this.

:thumbup:

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...