Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Kmfish87

1995 Response issues

Recommended Posts

Kmfish87

Took my 95 response out for the first run since i bought her earlier this week today and had a few minor issues. 

1. A few minutes after lunching she started running hot so I slowed to a stop, raised the hood and let the engine cool off. I started and ran a few minutes a couple times and the same thing happened each time. I finally gave up and turned around to go home and what would you know the temp dropped to 140 and never came above 180 the rest of the day. I'm assuming this was just an air lock by the temp sender. Is there a way to prime the system upon first launching or was this a fluke?

2. The engine bogs down on the top end (3500rpm and up). It will get up on plane quick and run fine. Running above 3000rpm, punch it and it will speed up to about 3500 then the engine will bog down and start slowing till you back off the throttle.

I am planning on putting in new plugs and fuel/water filter this week to see if that makes a difference.

What plugs should I use? I have the efi 350. The great interwebs tell me to use ngk br6fs...is this right? Any better options?

Is the only fuel filter near the front of the engine or is there another hidden somewhere? Looks like the fuel/water I can use a wix 33226.

Thanks for all the help! Hopefully next weekend will be more trouble-free...

Share this post


Link to post
Steve B.

You should have an inline fuel filter on the top of the engine too. A small metal cannister one? Definitely change that out. I think the plugs you mentioned are right. The resources section here may confirm that. How hot was the engine when it faltered at those rpm's?  Change the rotor, distributor cap too.

Fresh gas in it? Clean the umbelical connection. Near the rear, starboard side of the engine. Make sure battery connections are good and at starter too.

Steve B.

Share this post


Link to post
Kmfish87

Engine was less than 160* when bogging down. Filled her up with ethanol free from racetrac on the way to the lake.

Sorry for my ignorance but what is the umbilical connection? We talking fuel, water or electrical? 

Share this post


Link to post
Malibu Jordy
4 hours ago, Kmfish87 said:

Engine was less than 160* when bogging down. Filled her up with ethanol free from racetrac on the way to the lake.

Sorry for my ignorance but what is the umbilical connection? We talking fuel, water or electrical? 

I believe he is talking about the main wiring harness cannon plug.  Its a good idea to take it apart, clean the connections with a small pipe cleaning brush and electro contact cleaner, add some dielectric grease and put it back together. Probably not causing your issues but its a good maintenance practice.

Share this post


Link to post
Woodski

@Kmfish87:  In addition to checking or simply replacing the fuel filter(s), check to make sure the anti siphon valve on the fuel tank vent line is not blocked as that can create a vacuum condition in the fuel tank.

Share this post


Link to post
SmoothWaterMan

You stated you have an "efi 350" - Which brand?  Do you have an Indmar Monsoon, or a Mercruiser (Merc Mag 350/265, Merc 300PFI?)

Share this post


Link to post
Kmfish87
1 hour ago, SmoothWaterMan said:

You stated you have an "efi 350" - Which brand?  Do you have an Indmar Monsoon, or a Mercruiser (Merc Mag 350/265, Merc 300PFI?)

It's a mercruiser and I believe it to be the magnum 265.

Share this post


Link to post
Kmfish87

Changed the fuel filter and spark plugs last night. This is what came out of the fuel filter:

Hoping that was my top end issue...

20160804_181945_zpsqrhabmwv.jpg

edit: sorry for the gigantic picture

Edited by Kmfish87
picture size

Share this post


Link to post
Steve B.

Is that oil, or gummy gas or water?  Cool pic though !

Steve B.

Share this post


Link to post
Kmfish87
2 minutes ago, Steve B. said:

Is that oil, or gummy gas or water?  Cool pic though !

Steve B.

Nasty old water-logged gas. It smelled like stale water with a slight hint of gas. Hopefully I have gotten rid of most of this. Boat had less than 1/4 tank in it when I bought it, filled it up and ran 1/2 tank out last weekend and will fill it up again tonight to spend the weekend on the lake this weekend. Think I'm gonna grab a spare fuel filter to keep with me just in case...

Share this post


Link to post
Steve B.

If you haven't already, I'm thinkin' syphon the rest of the fuel out of the tank, and use it in a lawn mower if it will run. Dont run that gunk in your ski boat.

Good luck,

Steve B.

Share this post


Link to post
Kmfish87

Ran a little better this weekend. Will run up to 3800rpm before it starts bogging now. Going to replace the fuel filter again and see if it's full of the same crap again. If so I'll be draining/cleaning the tank. Also going to check the base timing and replace the cap and rotor. 

Is is there a good coil upgrade for these efi engines that won't break the bank? The one that is on there is a factory/original looking...probably a little tired after 21 years and 600 hours

Share this post


Link to post
Bozboat

Did you Check the fuel pressure?

and you probably should send the injectors out for a clean and rebuild.

not that expensive and you can get a quick turn around. having mine rebuilt was easily one of the better things I have done to the boat.

Share this post


Link to post
Kmfish87

I have not checked fuel pressure yet. on the to-do list next time I work on it as well. 

Any recommendations on where to get the injectors rebuilt for a TBI engine? I'm near Atlanta, GA

Share this post


Link to post
Andrew63

Not sure if applicable but I found this an interesting read & marked it to follow so I could find it again if needed

 

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...