Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
powderjay

Done with my echelon! vapor lock

Recommended Posts

powderjay

Where to start??  I love to ski and the lsv is not a ski boat..  So I picked up an older echelon sight unseen, yes I know.  Great boat when running and great slalom wake, but if you shut her off and try and come back for a set,  for get it!  You have to wait hrs for that thing to cool down and start back up!   Loved the 2 boat idea for tubing the kids and all but she is just not as reliable as I'd hoped.  I've tried lots of things and am done fiddling..  only thing is how do I sell this thing knowing the problems she has??  

Share this post


Link to post
Woodski

@powderjay:  sorry to hear your struggles.  Vapor lock should be solvable & you are not at a latitude that is overly onerous.  Going on the assumption it is a Mercruiser carbed 350 tournament ski engine, I assume you have verified the fuel pump works properly & fuel lines are clear and not kinked, anti siphon valve is free, the blower is functional, any and all engine vents are open and clear (particularly from the front inlets under the windshield to the bilge) and your carburetor is in good shape?  Other possibilities do fall on the electrical side, coil getting too hot or ignition system too weak to fire when hot.  Do you still have same problem if you leave engine box open between sets?  If same problem still persists may not be vapor lock.

Share this post


Link to post
powderjay

it's the 454..  just tired of loosing time on the water trouble shooting this thing.  Summer is short in Michigan, especially when you work all week. Need a boat that's a little more reliable.

Share this post


Link to post
MalibuNation

Seems to be a bad year for vapor lock.  Have you seen this thread?

 

Share this post


Link to post
gordon20mxz

powder,

I understand part of your issues.  I want to have a second boat that is a direct drive also and I am shopping around now.  Obviously there are budget considerations when wanting to have a 2nd boat just for skiing.  I am thinking I have to get to model years that have electronic fuel injection and hearing your problems confirms that I need to look for that.  I am sure there are many carbed boats that run fine, I just don't want to deal with it.

I am not attached to any brand.

I almost bought a 1995 MC 190 Pro Star long distance and sight unseen, but decided not to and wait for something relatively close that I can see and test.  Your experience confirms that for me also.

Sorry about your issues, I hope you get it worked out and get your boat reliable.  Your story is an important post, I am glad you are discussing it.

Share this post


Link to post
Michigan boarder

Have you messaged JBFoot?  He had had fantastic success with the 454's, has owned a few of them and has sought them out.  Could probably help you fix the issue.

Share this post


Link to post
TCdave

Our carbed sporty used to vapor lock all the time, switched to non-ethanol and problem solved. Still runs great and starts every time.

Quote

 

 

Share this post


Link to post
Steve B.

Exactly, change the source of your gas. Prop the cover between sets, run the blower and vary the time you are setting between sets.

Steve B.

Share this post


Link to post
Gavin17

Our carbed IO had vapor lock problems on hot days but I didn't think EFI engines would.  Mine hasn't ever but now I'm scared.  I need to start studying my fuel system in case I ever have issues I need to trouble shoot on the water. 

1 hour ago, MalibuNation said:

Seems to be a bad year for vapor lock.  Have you seen this thread?

 

 

Share this post


Link to post
formulaben

I added the $70 Carter secondary pump and haven't had it since...

Share this post


Link to post
MalibuNation

A lot of us with EFI are having vapor lock :cry:

Share this post


Link to post
Nitrousbird
8 minutes ago, MalibuNation said:

A lot of us with EFI are having vapor lock :cry:

You've had vapor lock on your LS1?  I've had mine in the most ideal of conditions this year to have vapor lock and not even a hint of it (running no blower, heavy surfing, shutting off between sets, hanging out for a while in the sun then firing it back up, etc).  I never heard of the LS1 having this problem.

Share this post


Link to post
jbower

I did the efi swap on my response that was a Merc 350 and did a setup just like I showed and never had vapor lock again

Share this post


Link to post
95echelon

EFI can still vapor lock... Our echelon did it a ton on hot days. Aside from the usual prop the cover, we added a permanent blower that ran with the key on as well as the switched one (moved twice the air) and poured water on the fuel pump as well. Just had it this week on my monsoon 340 EFI. Water over the fuel pump saved the day. It got hotter that week and I just used no-ethanol gas and it went away.

Share this post


Link to post
powderjay

Don't want to prop the top, buy extra blowers and pumps, ect, ect.  ran non ethanol but now that's a problem because the gas station is a 15min boat ride away and I'm afraid I'll have to spend the day there after I fill up!!  My old Supra never did this.. I just want to ski when I want to ski.. Is that too much to ask??   Looking to dump this thing and get into something more reliable. $$$  fire sale on my boat with newer dual axle trailer 6k come get it:Frustrated:

Share this post


Link to post
jbower

Yes I understand efi can still vapor lock. But typically doesn't happen on mercruisers design that system uses a vapor separating tank to keep that from happening also some other mercruisers have a water cooled fuel pump. 

Share this post


Link to post
95echelon
4 minutes ago, powderjay said:

Don't want to prop the top, buy extra blowers and pumps, ect, ect.  ran non ethanol but now that's a problem because the gas station is a 15min boat ride away and I'm afraid I'll have to spend the day there after I fill up!!  My old Supra never did this.. I just want to ski when I want to ski.. Is that too much to ask??   Looking to dump this thing and get into something more reliable. $$$  fire sale on my boat with newer dual axle trailer 6k come get it:Frustrated:

Don't threaten me with a good time! If you sold it to me I would toss the extra pump in there and go on my merry way, or just deal with it. Happened to me this weekend in 99 degree temps with 90 degree water in Missouri. One cup of cooler water on the fuel pump and off I went...

Sack up and do the fuel pump fix. Also it wont be 90+ degrees near us forever.

5 minutes ago, jbower said:

Yes I understand efi can still vapor lock. But typically doesn't happen on mercruisers design that system uses a vapor separating tank to keep that from happening also some other mercruisers have a water cooled fuel pump. 

They even flew Mercruiser engineers out to add the water cooled fuel pump on the 350 EFI ours had, it helped a ton but never solved it 100%

Share this post


Link to post
MalibuNation
43 minutes ago, Nitrousbird said:

You've had vapor lock on your LS1?  I've had mine in the most ideal of conditions this year to have vapor lock and not even a hint of it (running no blower, heavy surfing, shutting off between sets, hanging out for a while in the sun then firing it back up, etc).  I never heard of the LS1 having this problem.

NB, IIRC we've talked about this since we have somewhat similar setups.  Yes I have vapor lock on my LS1.  All started when ethanol was added to gas.

Share this post


Link to post
Michigan boarder
30 minutes ago, powderjay said:

Don't want to prop the top, buy extra blowers and pumps, ect, ect.  ran non ethanol but now that's a problem because the gas station is a 15min boat ride away and I'm afraid I'll have to spend the day there after I fill up!!  My old Supra never did this.. I just want to ski when I want to ski.. Is that too much to ask??   Looking to dump this thing and get into something more reliable. $$$  fire sale on my boat with newer dual axle trailer 6k come get it:Frustrated:

You are making an emotional decision.  You can buy another Supra and have a whole host of other problems to deal with and throw money at.  Those are all solid suggestions from people that eliminated the problem, so they are valuable.

However, if you still want to move it, I will come and get that boat for $6k. 

Share this post


Link to post
67King
12 minutes ago, MalibuNation said:

NB, IIRC we've talked about this since we have somewhat similar setups.  Yes I have vapor lock on my LS1.  All started when ethanol was added to gas.

I wonder if maybe the fuel lines and fuel rail are where the problem lies.  If so, you might try keying on and off several times to prime it with liquid gasoline.  I think most of the time, the problem is with the mechanical pump, which is on the engine, rather than the electrical one, most of which are in the tank.

Share this post


Link to post
DUKENO1

I am dealing with it too...happened yesterday.  Cold water on the fuel pump and it fired right up.  I will say I saw a guy with a very clean Echelon as I was leaving.  Sexy boat! 

Share this post


Link to post
67King
3 minutes ago, Michigan boarder said:

You are making an emotional decision.  You can buy another Supra and have a whole host of other problems to deal with and throw money at.  Those are all solid suggestions from people that eliminated the problem, so they are valuable.

However, if you still want to move it, I will come and get that boat for $6k. 

Shhh......I want him to throw in the towel and sell it really cheap.  I'd love to start actually skiing again.  Wake behind the Axis (3500#) was tolerable, not so the VLX (4300).

Share this post


Link to post
Michigan boarder

I'm dead serious - our ski team could really use that boat, it would be a great addition.
 

Share this post


Link to post
MalibuNation

67 I have tried the keying trick and the only fix has been to get a towel wet to cool the fuel lines, rails, and pump.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...