Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
gueroguero

Medallion MDC 1600 Gauge Module

Recommended Posts

gueroguero

Hello everyone, I have a 2001 Wakesetter lsv and the polarity on the battery was reversed. It was fixed by replacing the ignition control module and the boat now starts and runs. When the polarity was reversed, all the gauges stopped working. All the fuses look good. I bypassed the kill switch and the gauges still don't come on. I'm looking to replace the MDC gauge module and I see there are different ones available.

The one on my boat shows "Medallion MDC 1600" and the label shows 6607-20008-01 F and underneath it says "AutoSelect." I've seen Medallion MDC 1600 but the label shows a different number. Does the MDC have to match up exactly? I've seen some where it says that the MDC may not work due to firmware differences and/or the module being newer. Any help is appreciated or if anyone knows of any alternatives instead of using the existing gauges with the MDC.

Thanks!

Share this post


Link to post
Mister T

Just ordered a replacement for my 2002 Sunsetter, with the help of my good friend who also had to replace his, and referred me to Jim Taylor at Coldwater Lake Marina in Coldwater, MI.  Jim can be reached at Toll Free: (888) 262-1719.  With the number in hand he was able to order the correct replacement (there are apparently different modules/models of the Medallion MDC 1600.  It is a pricy part, but Jim made the ordering and subsequent shipping to me pretty painless.  Good service, so if you are still in need of the part, give Jim a call.

Share this post


Link to post
Shastasurf

I thought I read a thread on deleting the medallion and saving the $$$.

Share this post


Link to post
Freeflyer

I just replaced my 6607-20008-01 F Autoselect MDC-1600 with the one that Bakes sells.  There MDC 1600 doesn't say Autoselect on the unit though.  Instead it says "MDC w/ Speeds."  Anyways, I put this new unit in and all my gauges came back except for my speedometer.  I haven't put any compressed air into the unit yet to see if I just have a problem with my tubes but my speedometer was working before the MDC crapped out on me.  Maybe it was mislabeled and should of said "w/o Speeds" haha

This is for a 2002 Malibu.  Anyone have any good old school input on this?  

Share this post


Link to post
UWSkier

don't use compressed air.  You'll blow out the check valves and will be replacing your MDC again due to water getting inside.  Use the left-right selector switch.  If both of them are reading zero, you probably don't have a blockage in the pitot lines.  Check the connection on the back of the speedo.  Try swapping it with another gauge.

Does the speedo needle do the spastic buzz when you key on?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...