Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
beleza

Quick help!!! Maliview screen stuck on Media screen

Recommended Posts

beleza

I have a 2010 23lsv. I'm out at lake powell with it for the first time and of course I'm having a problem the first day on the water. I've put over 10 hours on the boat with no issues. This time out, as soon as I changed the screen on my dash to the MEDIA screen I cannot get it to change. It is stuck on the MEDIA screen. I've tried turning the batteries off and restarting with no luck. The functions within the media screen work (video 1, video 2, etc) but I cannot get it to switch to any other screen. No gauges, no perfect pass, etc. Anybody have any solutions or things I could try? Just don't want to spend our entire trip without a speedo, cruise and engine temp info. Any help is much appreciated! 

Share this post


Link to post
mikeo

Do you have MUX switches? If so, one of them may be "jammed" (either a button is stuck, or it may have water in it). Try unplugging any MUX switches to see if you can regain control of the other functions.
For reference, MUX switch:
muxleft_LG.gif

Share this post


Link to post
beleza

Yes I have MUX switches. I checked them and tried unplugging them. No dice. Still won't change off the MEDIA screen. 

Share this post


Link to post
hunter77ah

Is there a "back" button? Lower left on screen?

Share this post


Link to post
Roush611

Have you tried disconnecting the battery for a bit? 

Share this post


Link to post
beleza

I haven't tried completely disconnecting the battery yet. I will give that a try

Share this post


Link to post
Roush611
1 hour ago, beleza said:

I haven't tried completely disconnecting the battery yet. I will give that a try

Any luck?

Share this post


Link to post
beleza

No luck. We've just been using it like it is. We get back home on Monday so I will see if I can figure it out when I get back

Share this post


Link to post
beleza

Well after having the battery disconnected for a couple days my screen works again. I guess I will just keep an eye on it. Kinda weird. Hopefully it's not a reoccurring issue. Thanks for the help!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...