Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

2010 wakesetter lcd screen is blue and unresponsive


Recommended Posts

so I just had my stereo amps replaced and took my boat out for the first time and the lcd screen is bright blue and unresponsive.  I have done hard restart with the perko switch.  check all the cables are firm and secure.  anyone know what could cause this issue.  THANKS 

Link to post

The blue cable is the only cable for the dash screen and it is the conduit for the signal to the screen from the black box. If you have an active screen, but it is only blue something is telling me that the input signal to screen is the issue. I would recheck the connections behind the amp board to make sure that some of the wires did not get crossed. 

Link to post

if we are talking about the Maliview (big center screen at top of dash), I'll betcha a dollar that there is an RCA cable unplugged behind the dash.  That screen gets its video signal through a single RCA.

Link to post

we checked the rca's behind the screen both firmly seated.  what is behind the amp board.  my stereo is not connected with the Malibu lcd.  thanks!

 

Link to post
6 hours ago, ameyer said:

we checked the rca's behind the screen both firmly seated.  what is behind the amp board.  my stereo is not connected with the Malibu lcd.  thanks!

 

Everything stereo related! The RCAs from the black box to the amps to deliver the associated radio/Sirius/aux input signal, iPod connection, video connections for the Malivue, CD connection which will not work on '10s and newer according to RF, FM antenna receptacle, dash remote RF-55MR, the poorly engineered electrical power harness for the radio:  main power (yellow), clock power (red),  remote turn on (blue), ground (black) and 1pr 2 other plugs which I am forgetting.

Link to post

so I abandoned the jbl black box and went to the RF black box a few years ago.  the stereo was disconnected from the viper blue box and lcd screen.  we tested the cable and it is good. I found a viper blue box for 750 from boulder boats in phoenix.  should I try that at this point.  just trying to get my boat working for the season.  thanks everyone.   

Link to post

can you plug in something else to the maliview screen?  An ipod with video cable, or an old vcr or something, just to make sure that the screen itself does actually work?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...