Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
bankshk

4000RPM at IDLE

Recommended Posts

bankshk

hey guys,

i have a 2006 Malibu Wakesetter 23LSV with a Indmar Monsoon 340 EFI.

Been troubleshooting this problem for about a month now, driving me crazy!!

Was towing and the rider fell, i throttled back to neutral and the engine RPM just shot up to 4000RPM. Every time i start the boat it does the same. No error codes on a diagnostics tool however, i notice that the IAC is showing 84.6% (roughly 4000rpm?) I have changed the Pedal Position Sensor and the throttle intake as the TPS sensors are built into that. The voltage across the PPS 1 + 2 and TPS 1 + 2 seem to indicate normal at different throttle positions, however, the IAC still shows 84.6% despite changing the sensors, and the problem is still there. Reading the MEFI 5 manual it says the IAC is built into the throttle body fly-by-wire which i have already replaced.

Is there a faulty wire between the ECM and throttle body? Any other suggestions would be so much appreciated.

Thanks

 

Share this post


Link to post
bankshk

Any help guys? 

Share this post


Link to post
MotoGPTy

Do you have Perfect Pass on the boat?

Share this post


Link to post
bankshk

no, just the standard 'malibu cruise control' that was engaged at the time till i throttled back. it shows that it is not armed or on at the moment - would it be worth disconnecting the computer screen from the dash?

Share this post


Link to post
MotoGPTy

Not sure, I have a 2004 LSV and it has the "rope" style Perfect Pass control box mounted on a raw water hose that tightens and loosens to adjust throttle.  If you have something like that, you may have someone start the boat while you are watching for it to engage and possibly be giving it throttle.  I searched the 06 manual and there doesn't seem to be a cruise control reset or troubleshooting section.  Perhaps another 06 owner can help here?  

Share this post


Link to post
Engine Nut
On Wednesday, May 11, 2016 at 8:12 AM, bankshk said:

hey guys,

i have a 2006 Malibu Wakesetter 23LSV with a Indmar Monsoon 340 EFI.

Been troubleshooting this problem for about a month now, driving me crazy!!

Was towing and the rider fell, i throttled back to neutral and the engine RPM just shot up to 4000RPM. Every time i start the boat it does the same. No error codes on a diagnostics tool however, i notice that the IAC is showing 84.6% (roughly 4000rpm?) I have changed the Pedal Position Sensor and the throttle intake as the TPS sensors are built into that. The voltage across the PPS 1 + 2 and TPS 1 + 2 seem to indicate normal at different throttle positions, however, the IAC still shows 84.6% despite changing the sensors, and the problem is still there. Reading the MEFI 5 manual it says the IAC is built into the throttle body fly-by-wire which i have already replaced.

Is there a faulty wire between the ECM and throttle body? Any other suggestions would be so much appreciated.

Thanks

 

The PPS (Pedal Position Sensor) is located in the throttle control handle. When the engine is running at idle, the PPS position or angle should be at 0%. This system does not have a separate IAC (Idle Air Control) valve. The IAC function is accomplished by the ECM controlling the throttle plate. The TPS is located in the throttle body assembly and id just there to report the position of the throttle plate back to the ECM ... the TPS does not control the position of the throttle plate.

Share this post


Link to post
bankshk

thanks for the replies.

i understand that the IAC is built into the throttle body, but the PPS and TPS sensor voltage all seem to indicate normal on my TechMate. The throttle plate is also in the 'closed/idle' position when firing up, its certainly not anywhere near WOT or even a quarter open. The TechMate does show that he IAC is at 85% though - see attached, sorry for the poor quality.

 

 

Screen Shot 2016-05-18 at 6.49.28 pm.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...