Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
jeffro

JBL Black box will not turn on

Recommended Posts

jeffro

I have a 2010 VTX with the JBL black box, and when I put the battery in this year it will not come on, blank screens on mux switches (no volume shown), remote in the walkway (completely blank), and maliview.  I checked the in line fuses to the black box and they are good.  I have a separate amp for the tower speakers and it powers up, but nothing on the black box.  I checked all the fuses under the dash, and the breakers under the throttle, everything looks good.  I've followed all the wires I can see and everything appears to be connected, and everything worked fine when I put it away in the fall.

Any ideas?

Share this post


Link to post
jbower

Make sure all wires are connected to the battery. 

Share this post


Link to post
mikeo

Pull the inline fuses and check for corrosion. I would also get some jumper wires (not jumper cables) and power the black box from a direct battery connection, don't forget the "remote" wire; the colors depend on the version of the black box you have there should be three wires: positive, negative, and remote. Don't get the remote wire confused with the amp remote. The "remote" wire is so that the black box can always get power, but turn on when you turn a key, press a button, etc. You can tie the remote with the main power lead for testing. Make sure the black box display (Rockford Fosgate calls this a remote) is directly connected to the black box, and then observe it when you apply power.

It may be something simple like corrosion on the pins of the remote control/display or it could be a more catastrophic failure. If the "jump" test doesn't work I would try to find someone with a compatible remote so you can test that before calling the black box dead.

Edited by mikeo
typos

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...