Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
jrvs23

Bilge pump

Recommended Posts

jrvs23

At the end of last season I noticed my bilge pump wasn't working. Flip the switch and nothing. Went to take it out today and inspect it and it won't move. How is it mounted other than being in a extremely difficult spot? I couldn't see any screws or bolts. Maybe siliconed from factory so it doesn't slide around? Please shed some light.

Share this post


Link to post
electricjohn

Mine had a few short screws into the hull.

Share this post


Link to post
wdr

Mine is epoxied and if I replaced it I would epoxy the new on back in. Really no need for screws, it is not heavy or a torque monster and the drain line as zip tied by Malibu pretty much hold mine in place anyway. As a matter of fact when I replaced the pump on my former boat I pulled the old one out, cleaned that spot with mineral spirits, pulled the new base off of the new pump and using a liberal dose of marine adhesive reattached it to the hull. Didn't have one problem out of it.

Edited by wdr

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...