Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
stoffs

Suspected Throttle Position Sensor Issue

Recommended Posts

stoffs

Hi guys,

I own a LSV 23 2008 with the Indmar engine. I was out boating the other week and when I reduced the power the engine would not respond to me. When I came back to idle and out of gear the engine just continued to stay at 4000 + rpm, before I shut it off. Since then I've been unable to start the boat without the engine RPM increasing to over 4000. My initial thought was that one of the cables behind the throttle panel had become jammed or stuck but Ive checked behind there and it all seems in working order. Ive checked the butterfly valve on the air inlet and it is operating as it should. So I then thought maybe it has something to do with the Throttle Position Sensor behind the throttle panel. So I've gone ahead and replaced that sensor as it was only $50. Tried to start the boat today, still no joy. Same issue. Question I have is, do I need to program the TPS? How does the ECM know what idle is when you connect a new TPS? Do I need to use a diagnostic computer to reset it? If anyone has any other ideas that I haven't thought of I would be very grateful.

Cheers,

Chris

Share this post


Link to post
Andrew63

Don't know a lot about these but a quick Google search produced a few possibilities & short videos which may hold a clue.

Found this again may point you in the right direction

http://www.themalibucrew.com/forums/index.php?/topic/15011-occasional-high-idle-and-rough-runningmiss-fire/

Post 5 in the link below from Bakes is interesting

http://www.themalibucrew.com/forums/index.php?/topic/28351-padel-position-sensor/

Send a PM to the poster of reply 9 in this thread, sounds like it may be the fix if they are still on this forum.

http://www.themalibucrew.com/forums/index.php?/topic/27863-electronic-throttle-control/

Edited by Andrew63

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...