Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
hunterlewis

Loss of power at hole shot

Recommended Posts

hunterlewis

My 2003 wakesetter 325 monsoon is cutting out at beginning of acceleration.idle and top end are fine. New plugs,cap,rotor,fuel filter did not help. bout 500 hrs on motor but was running great 3 weeks ago. New gas with stabil. cables look ok. any ideas? thanks

Share this post


Link to post
grandude

Clogged fuel injectors.

Share this post


Link to post
hunterlewis

Do any of the fuel additives work or do they need to be pulled?

Share this post


Link to post
grandude

They need to be pulled. It's not as big of deal as it seems. The most common issue is getting clogged with sediment. Typically the first two or three on the inlet side rail are the worst, but all need to be cleaned up. I would pull them out and have a fresh can of carb cleaner with a spray straw. I'd clean out the top of the injectors over a Tupperware container to catch the product that comes out of the injectors. I would have some Vaseline or similar for lubing the o rings to re install them. You are welcome to PM me if you wanna talk one on one about procedure.

Share this post


Link to post
brad72

I would also check the inlet screen on the fuel pump. It will produce a similar result if dirty.

Edited by brad72

Share this post


Link to post
grandude

The whole procedure is less than an hour if you follow the steps. I've seen several friends boats with the same symptoms and service items already done. Several of these the injectors looked like someone had scooped up some Skoal and packed in the inlet. Cleaned out and boats have run great.

I would check the inside of the elbows on the fuel rails. On one friends boat we identified these elbows as the source of rust particles clogging things up for a second time.

Share this post


Link to post
JasonK

Make sure you change all your fuel filters. some have 2.

Share this post


Link to post
hunterlewis

Ok thanks. Will look at it and see if it is something I want to tackle

Share this post


Link to post
Levi900RR

My monsoon seems down on power in general. Seems to be running just fine but it's not coming out of the hole like it used to. I'm going to check the injectors. Seems like a decent place to start

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...