Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Cory

Compass on 2015 Dash?

Recommended Posts

Cory

I've noticed some YouTube videos where the 2015 maliview screen has a compass on the upper right side of the screen (opposite engine hours). My dash has "--" in this location. How do we get the digital compass working? Is this one of those features that wasn't ready for early build 2015 boats? Or, is there a firmware update?

Share this post


Link to post
mikeo

I thought it was part of the Zero Off GPS, but I've got both antennas on my boat; I'll go unhook each one and see when the compass disappears and reappears as soon as I finish my (late) lunch.

I just checked and the compass reading took about one minute to show up after starting the computer; It was -- until it locked in on a signal. I pulled both antennas and the reading stayed, so I'm not sure which one it's reading from. If I had to guess, I think it's reading from the zero off antenna since the chartplotter antenna is an add-on option.

Edited by mikeo

Share this post


Link to post
Cory

Do you have the maps option? Maybe the compass comes when you pay for map data.

Share this post


Link to post
Excel516

Mine has the compass. I also have the map option.

Share this post


Link to post
saidainc

My 2012 has the compass, although its in Sharpie and kind of not accurate.

Share this post


Link to post
mikeo

I don't have the chartplotter turned on, so the compass is not part of the maps option specifically. In theroy to get direction data you must be moving or have a gyroscope/3d accelerometer to be able to figure out what way you're going. The compass displayed a direction within 1/2 second of the GPS lat/long populating in the settings, so my bet is that the compass is tied to the zero off system.

Check for GPS data in the 7" screen settings (not chartplotter) to see see your getting any signal. Picture:

post-3087-0-92760800-1436667043_thumb.jp

Edited by mikeo

Share this post


Link to post
Cory

I use GPS speedo, so I know the GPS antenna is on and working.

Share this post


Link to post
mikeo

What software/firmware version is your dash system running? I believe mine is running 022015, but that's from memory... Also, how old is your boat? I can see it's a '15 in your profile, but when was it built/when did you take delivery? There are two different computers that have been used in the '15 boats, and the easiest way to tell is if you have a 3" antenna screwed in the back in the WiFi terminal. Despite it being labeled WiFi, it's the bluetooth antenna and the early '15 boats with the "old" computer didn't have an external antenna. It's possible that something isn't quite right in the computer if you have the old version and no compass display.

Keep in mind that for an electronic compass to work correctly you need to either be moving or have a 3d accelerometer/gyroscope. I think the reason I got a reading in the driveway was that GPS was in the process of acquiring signal, the boat was facing West, but displayed NE. If you don't get a bearing while moving there is a problem.

Share this post


Link to post
Cory

My firmware is 022015. My boat was built in January, but my dealer swapped out my MTC unit for the newer unit. I do have the 3" antenna on the backside. I will pay attention the next time out on the water to see if the "--" changes to a direction when underway. I don't recall ever seeing anything other than the "--". I'm at 45 hrs now.

Share this post


Link to post
bunji169

I have a July '15 build boat without chart plotting. 022015 firmware. I have -- on my dash too. Never seen it change to anything else.

Share this post


Link to post
Cory

I don't have the chartplotter turned on, so the compass is not part of the maps option specifically. In theroy to get direction data you must be moving or have a gyroscope/3d accelerometer to be able to figure out what way you're going. The compass displayed a direction within 1/2 second of the GPS lat/long populating in the settings, so my bet is that the compass is tied to the zero off system.

Check for GPS data in the 7" screen settings (not chartplotter) to see see your getting any signal. Picture:

attachicon.gifgps.jpg

When you say "I don't have the chartplotter turned on" does this mean you did purchase the chartplotter option (i.e., the map data). If so, perhaps the compass option was enabled when the map data was uploaded into the chartplotter? I don't have interest in purchasing any map data, but I wouldn't mind the digital compass working. I can be orientationally challenged at times.

Share this post


Link to post
mikeo

When I said "I don't have the chartplotter turned on" I was referring to I don't have the SD card installed and I'm not displaying the chartplotter on the 7" screen. I have one card for two boats and I need the chartplotter in the other boat, I don't need it in the LSV.

I have this antenna attached to the back of the 7" display/computer:

http://www.amazon.com/gp/product/B00LXRQY9A?psc=1

I can't say I outright recommend this antenna for two reasons: I'm not sure the specs that the Malibu/Medallion system is expecting so I went with a generic antenna that facilitated a wide signal range AND I'm not getting any WAAS signal. I should be able to get WAAS signal with any antenna, but I'll have to save that for later troubleshooting. I don't know anyone who got the factory option chartplotter GPS antenna or maps, so I've only been able to verify the maps SD card by talking to Medallion and Navionics. I need to find out what the correct specs for the antenna are.

When I disconnected the GPS antenna (not Zero Off antenna) nothing changed on the display for the compass. I'm stuck at a conference for work this week so I can't do any testing until Saturday at the earliest now. I'll pull the GPS antenna off and power cycle (perko switch) the boat to make sure the computer is "cold booting" with the GPS antenna disconnected and see if I get a compass reading. As I recall I could see signal from 2-3 satellites in the chartplotter screen even without the GPS antenna, but it was weak signal. The GPS antenna boosted the signal and was able to "see" more satellites.

Share this post


Link to post
Cory

Mikeo,

We had the boat out last night. The "--" does not change to a heading value when underway. I checked the System Diag. settings and everything under GPS (Latitude, longitude, COG, SOG, time, Date) are zeros. If I get that antenna you posted above you think that will make the difference? The antenna I thought you were describing earlier is a 4" monopole antenna on the backside of the MTC unit. I do have that antenna, but I doubt I have that puck antenna you linked to. I do have the newer MTC, my dealer swapped that out a couple months after I got my boat when the newer ones were released.

Share this post


Link to post
thtrog

My compass worked before loading the new firmware, didn't notice until this thread it's gone --

B88ED479-063E-4190-855E-9964436F7642_zps

Edited by thtrog

Share this post


Link to post
Cory

Hmmm... I want my compass back!!! This is a safety issue. I could get lost, run out of gas, and never return to the real world...

Share this post


Link to post
Cory

Mikeo, you should confirm your firmware rev number to see if that is the issue per Thtrog's comments above.

Share this post


Link to post
mikeo

I'm stuck at a conference this week and am a 3+ hour drive away from my boat. Going from memory, since I don't have a picture, my firmware is 022015. I'll be able to verify on Saturday at the latest, possibly Friday night.

Share this post


Link to post
mikeo

I was out at my boat yesterday and I can confirm that the compass is tied in to the GPS antenna input next to the bluetooth antenna. I disconnected thr GPS antenna and then turned on master power (perko) and then booted the dash system, no GPS and no readings in the diag screen. I powered everything down, connected the GPS puck, and turned it all on: compass in 5 seconds.

I did notice that I could get 2D (3 satellites) without an antenna when I was in an open area before I got the GPS puck antenna I'll post pictures in a few hours...

Share this post


Link to post
IXFE

Is the GPS antenna part of the maps option?

I don't have maps... trying to figure our if I should have the compass display.

Share this post


Link to post
DarkSide

Yes antenna comes with chartplotter option, but the chartplotter option does not include the maps card, you have to buy that deliberately. Navtronics hot maps premium, platinum will not work

Share this post


Link to post
IXFE

Yes antenna comes with chartplotter option, but the chartplotter option does not include the maps card, you have to buy that deliberately. Navtronics hot maps premium, platinum will not work

So chartplotter and maps are two separate options?

I remember that maps (the SD card) was an option that I didn't choose. But I don't remember there being a chartplotter option.

Share this post


Link to post
Cory

I was out at my boat yesterday and I can confirm that the compass is tied in to the GPS antenna input next to the bluetooth antenna. I disconnected thr GPS antenna and then turned on master power (perko) and then booted the dash system, no GPS and no readings in the diag screen. I powered everything down, connected the GPS puck, and turned it all on: compass in 5 seconds.

I did notice that I could get 2D (3 satellites) without an antenna when I was in an open area before I got the GPS puck antenna I'll post pictures in a few hours...

Can you snap a picture of where the GPS antenna plugs into? For $16 I may just buy one.

Share this post


Link to post
mikeo

Here are some pictures that I took related to the compass this weekend:

GPS Antenna Port (on the back of the 7" display)

post-3087-0-66767800-1437416791_thumb.jp

** Note that the port labeled "WIFI" that should have a small antenna screwed in to it is really a bluetooth port. If you don't have these ports then you have the "old" 7" display and may want to talk to your dealer/Malibu about replacing it.

Share this post


Link to post
Cory

I have the WiFi antenna. I may just order that GPS antenna you linked above. For $16 it's worth a shot.

Edited by Cory

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...