Jump to content
Sign in to follow this  
ViningVLX

Power Wedge - 2008 VLX

Recommended Posts

ViningVLX

I have a 08 VLX with a Power Wedge. After deploying, the wedge became stuck in the down position. I have done the following:

1 - Checked battery connections (good)

2 - Replaced the thermal fuse (30 amp version without the tab)

3 - Checked calibration of the sensor to make sure it is within the correct range for down. (good - 14)

4 - Checked Mux Power Module (led is blinking)

5 - Checked the MUX switch - Down button appears active. Up button produces nothing,

6 - Checked the Power Module 12 volt leads from the battey. (Good at 12.2 volts but figured that because everthing else seems to be working)

7 - Checked the black and white wires coming off the MUX Power Module to the Wedge. (Not good. No voltage reading on my multimeter)

Crew - Does anyone have any ideas or am I about to spring for a new MUX? Any assistance will be appreciated.

BV

Share this post


Link to post
Share on other sites
robbennett

Is the speedometer working? If it doesn't register that it is moving it won't go up.

Share this post


Link to post
Share on other sites
ViningVLX

Yep. Speed reading appears normal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×