Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Lakenut

01 Sunsetter gauges dont work

Recommended Posts

Lakenut

Getting the boat ready for the year..my gauges dont vibrate and come on. Engine runs fine...just no juice to the guages. I unhooked batt cables to see if that reset anything w no luck. Any ideas before dragging it to the dealer? Im hoping its a bad connection, not the mdc crapping out!

Share this post


Link to post
Share on other sites
BuNewb

I would pop of the pitot tubes connected to the MDC and see if they have water in them...

Share this post


Link to post
Share on other sites
racer808

Chances are your fuse to the MDC is blown, hot or ground is disconnected somewhere under the helm. Trace the wires back & see what you find

Share this post


Link to post
Share on other sites
tvano

kill switch?

Share this post


Link to post
Share on other sites
footndale

kill switch?

OP says engine runs fine, so probably not.

Share this post


Link to post
Share on other sites
tvano

OP says engine runs fine, so probably not.

my bad. missed it, thanks.

Share this post


Link to post
Share on other sites
Lakenut

All wiring is secure. There are 2 inline fuses...they look good but i will replace them next

Share this post


Link to post
Share on other sites
Lakenut

I pulled the speedo tubes and all was dry.....hmmm

Share this post


Link to post
Share on other sites
WakingMeHappy

Do you have power to the MDC?

Share this post


Link to post
Share on other sites
Lakenut

Thats my next check after fuses. Im a simpleton...whats the best way to check for power?

Share this post


Link to post
Share on other sites
WakingMeHappy

Simple volt meter.

Share this post


Link to post
Share on other sites
Lakenut

Hot dang..... $0.50 fuse is all it was!!!! Now...any special trick to reconnecting the speedo tubes so tgey dont leak?

Share this post


Link to post
Share on other sites
Bozboat

Oh, don't reconnect the tubes. Plug them. Use the tach to estimate speed or go with the GPS speedo upgrade kit

Edited by Bozboat

Share this post


Link to post
Share on other sites
BuNewb

Oh, don't reconnect the tubes. Plug them. Use the tach to estimate speed or go with the GPS speedo upgrade kit

This or zip ties is all that was on mine before I took them off. Many people have been burned by these speedo tubes, hence the suggestion for GPS.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...