Jump to content
mrnate450r

Low Oil Pressure 2014 LS3

Recommended Posts

mrnate450r

We took the boat out today with some friends to get some more break in time on it. All was well until we were going to take one last cruise before heading in. I got a low oil pressure warning. I stopped the boat and checked the oil. It was fine. So I power cycled everything and tried again. Same warning at about 2500 rpm. So I flip to the screen with the oil pressure, and it is pegged all the way to the right, so more than 80 psi. The actual pressure on the cruise screen showed 107 psi at idle and 120 psi at 2500 rpm. Boat ran fine all day until this point and all gauges were normal. My guess is a bad sensor. I would think at 120 psi I would have oil blowing out everywhere. Thoughts?

Share this post


Link to post
Share on other sites
04 VLX WINDERMERE UK

Just a thought, but we have had the same thing while surfing, with not enough weight in the bow, so the bow lifts up a lot untill the engine oil pressure started to drop. solved it two ways:- first slightly overfilled the oil and secondaly got a bow sack.

hope this helps

Edited by 04 VLX WINDERMERE UK

Share this post


Link to post
Share on other sites
Nitrousbird

Just a thought, but we have had the same thing while surfing, with not enough weight in the bow, so the bow lifts up a lot untill the engine oil pressure started to drop. solved it two ways:- first slightly overfilled the oil and secondaly got a bow sack.

hope this helps

Except he has high oil pressure.

I would also guess it is a bad sensor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×