Jump to content
Sign in to follow this  
ncarilli

Flo Cam Not Working? Anyone else have problems?

Recommended Posts

ncarilli

Hello all I have been looking around on here a few months due to me switching to Malibu over the winter, I was formally a correct craft owner but I am very excited about my Malibu. To make a long story short in January I bought a 2010 Malibu 247LSV with the LS3 motor off of my local Malibu dealer, the original owner used it one season (30 hours) then moved from the area and left it in heated storage for two years at the Malibu dealer. I bought it off of the dealer in the winter as a brokered boat but they assured me they sold this boat new and did all the service on it and they would go over everything before I pick it up in the spring to make sure everything in 100%. So I go to take delivery last week and before I make it down there they call to say everything is 100% except the Flo Cam doesn't work and Malibu wont cover it under warranty so if I want it to work I have to buy a whole new system for $2500. This is BS because I never even took delivery of the boat and it should be working but it seems the dealer is trying to screw me. Also how could the entire system be bad??? I'm sure I don't need the whole thing, has anyone else troubleshooted problems with the Flo Cam? Thanks!

Share this post


Link to post
Share on other sites
holden

Pm sent

Share this post


Link to post
Share on other sites
ncarilli

So it has now been two weeks of arguing with the dealership about who is responsible to fix the camera, I finally went down there to talk to the owner of the dealership and then he said he would fix it. Two weeks go by and I start bitching again and they respond and say that they tested the camera system and the whole system is bad! I find this hard to believe on a boat with 30 hours on it that the complete camera system is bad but they said they swapped out each piece and had to replace the whole thing but if I wanted it done it would cost $700.00 and the new system would only have a 30 day warranty from the manufacture with I feel is BS. What would any of you do? Anyone use their camera system much? Do you like it? Any issues with your system? I was excited it had the camera system but I hate to put out more money for something that should have been working in the first place. Im really starting to second guess this whole purchase and the dealer I bought it from! Any advice is appreciated. Thanks

Share this post


Link to post
Share on other sites
shawndoggy

aren't they still just using the vio pov cameras?

Seems way cheaper to replace it yourself.

https://vio-pov.com/pov-hd

Share this post


Link to post
Share on other sites
ncarilli

shawndoggy that appears to be the same thing but I was told a different company takes that system and makes it work with malivue so I'm not sure.

Share this post


Link to post
Share on other sites
holden

No, the camera is a vio. Link as provided. I had talked to the guys at vio and got a few extra lens protectors.

Medallion has customized the maliview.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×