Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Nwextreme

Install done and it Rocks!

Recommended Posts

Nwextreme

Share this post


Link to post
Share on other sites
saidainc

You installed a white background? Looks amazing!

Share this post


Link to post
Share on other sites
tjklein

Nice job. Looks like your install worked out perfect.

Share this post


Link to post
Share on other sites
Nwextreme

Thanks for all the feedback with putting my system together over the last couple months guys. After long delays with trying to get the noise to go away that the ws420 was creating it sounds sweet. As seen here i mounted the ws420 with the BT module in the new mount and it came out slick!! Absolutly love it!! Along with having that installed I had the exile 10" sub with custom box built at drivers feet powered by exile xi1500 and it pounds. Up top on the tower I had WS rev 8's previously but I stepped up and and am now powerring them with the WS syn 4 and they scream. I might upgrade them to the rev 10's down the road but we will see. I also had custom bow pods built for sound up in the bow for a total of 6 jl tub speakers powered by the jLm600/6. Overall very happy with the outcome piecing this all togehter thanks to all the feedback and info this board provided so Thanks!! Big shout out to Bakes for doing an awesome job as well!! Now i JUST NEED SOME SUN OUT HERE IN SEATTLE!!

Share this post


Link to post
Share on other sites
Pnwrider

It was 81 today and is supposed to be 85 tomorrow, what do you mean you could use some sun in Seattle? I need to find a crew for tomorrow since it looks like I'm "staying home with a sick kid"

Share this post


Link to post
Share on other sites
Nwextreme

Yea. It's like that during the week and supposed to rain over opening boating day this weekend. Wish I had time to play during the week

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
bunji169

What was final fix for noise issue?

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Nwextreme

Seamed like Running power from the head unit strait to the battery

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
TallRedRider

Seamed like Running power from the head unit strait to the battery

Sent from my iPhone using Tapatalk

Awesome install. I bet she sounds great!

Amazing how often the excess noise threads end up boiling down to the principle of doing all you can to get all of the grounds and power sources from the exact same place. It seems that solves 90% of excess noise threads.

Share this post


Link to post
Share on other sites
Try2paz

Sweet! How many rev 8s are you powering?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...