Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Asmodeus2112

Rust in Bell Housing :(

Recommended Posts

Asmodeus2112

The night before I bought this boat it was out in a rain storm, and I now think that the PO didn't pull the plugs after our test drive. Starter just failed, and there is rust in there. I'm thinking that it had excess water in the bilge that could have got on the flywheel and inside of the bell housing. But thought I might run it by ya'll for your opinion. Rust in the bell housing have any other causes? I'm checking everything that was down low...

Bell%20Housing%20Rust.jpg

Share this post


Link to post
Share on other sites
Asmodeus2112

Shoot, I cannot delete a post. I've been looking at it and I can see a high water line about 2/3 up the oil pan up front which puts the flywheel and bell housing in about 3-4 inches. I'm going to clean it up, get a new starter and get on with life. Please disregard this post....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...