Jump to content

 

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

MFASKI

Gauges not working

Recommended Posts

MFASKI

I have a 2001 Sunsetter VLX and all the gauges (Speed, RPM, Oil, Temp...) are not working. At the advise of the dealer I replaced the MMDC and that did nothing to resolve the issue. Does anyone have any trouble shoot tips or a wiring diagram that could help?

Thanks

Mark

Edited by MFASKI

Share this post


Link to post
Share on other sites
tvano

i'd start looking for a fuse that supplies power to the gauges.

Share this post


Link to post
Share on other sites
Eagle River Mike

There are 2 inline small amp fuses under the dash by the MMDC. 2 summers ago, all my gauges died and it was recommended that I replace the MMDC. Well it was the fuses. Less than $1 to fix. Glad I tried the fuses before I purchased a new MMDC.

Share this post


Link to post
Share on other sites
TNWILSON

May be a stupid question, but are the gauges not working while the engine is running? Reason I ask is when I was re-wiring my tower lights I turned they key one click to right to make sure everything worked (without starting boat) and noticed all my gauges including LCD display were dead. So I just assumed my luck is going as usual (messing with something I really don't need or care about and in the process screwed everything important up)! But turns out I accidentally pulled one of the wires off the kill switch plug-in. May be worth a look.

Share this post


Link to post
Share on other sites
MFASKI

Thanks for the help and ideas will start troubleshooting with these in mind.

Share this post


Link to post
Share on other sites
wienrdog

Some other things to check..

1) Your lanyard. The lanyard switch being off will also stop the gauges from working. Your boat won't start either.

2) You cannon plug. It's a large plug on the side of your engine computer secured with a tube clamp. Just wiggle it around & see if the gauges come back. Had problems with the tach a few years ago & that has taken care of it so far.

Share this post


Link to post
Share on other sites
MFASKI

Yes the MMDC is for sale

Share this post


Link to post
Share on other sites
MFASKI

I was able to resolve the 2001 Sunsetter VLX and all the gauges (Speed, RPM, Oil, Temp...) are not working problem with the help of a troubleshooting guide that I got from Scott Frye at the Medallion Tech Support (800-828-8127).

After disconnecting all the gauges and the main bridge harness I found that the signal coming from the MMDC output harness was reading 7 Volts as soon as I connected the harness the signal went away. I then removed the harness and looked for a short. Some idiot had installed a jumper wire from the gray grounding wire to the red white signal lead. I removed the jumper and all the gauges worked. Whoever maintained this boat either did not know what they were doing or deliberately sabotaged it to bleed more money out of the former owner.

At any rate the problem is resolved and I have a brand new MMDC for sale.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...