Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

2006 Malibu Wakesetter lsv striving for fuel


Recommended Posts

I have a 2006 Malibu Wakesetter lsv 23 with the 383 indmar hammerhead engine and this weekend it started giving us trouble. When in idle, the boat will run and rev up fine. When put under a load it sounds like it isnt getting enough gas, it will run fine then sounds like it isnt getting enough gas then it will run fine, etc. We took the filter outside the tank connected on the line off, cleaned it out and it wasnt much in it. Is there another filter inside the tank? Could this be the fuel filter? Any help would be great before we spend $300+ on a new fuel pump and it not be the problem. Thanks!!

Edited by Wkbrdr1989
Link to comment

You may need to replace the filter. Also check the screen at the fuel pump that you can clean. Fuel filters can look just fine but not pass fuel.

Link to comment

Also another detail we should include is the pump sounds like it is whining when in use

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...