Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Parker15

Gauge cluster shut-down

Recommended Posts

Parker15

I have a 2002 VLX (original owner) that since about 2004 has had a peculiar problem. Approximately every couple of minutes all of the gauges go dead for about 15 seconds and then come back up. My dash has speedo, oil, gas and battery which all go out. Battery is fine! Local dealer has looked at it a couple of times, but has no solutions. Now they just shrug their shoulders.

When I got the boat new, whoever rigged all the electrical had put a small screw thru the speedo hose about a foot behind the radio. For about 6 months i would notice water, but thought it was poor drainage from the built in ice chest. When i realized the water was draining down i found the punctured hose and fixed it. I think water might have corroded something along the way.

Does anyone have an idea where to start with fixing this issue?

Share this post


Link to post
Share on other sites
Sethro

Most likely the computer (MDC) that runs your Kysor Medallion gauges is faulty. My guess is that water found its way up the speedo tube into the computer and caused the failure. Water isn't supposed to get up there, but it does. Especially with the confirmed leak in your speedo hose. When there is an air leak somewhere in the system water will infiltrate all the way up to the speedo hose connections on the MDC. Trace your speedo tubes and you'll find where they connect to the MDC under the dash.

I can't believe the dealer would shrug his shoulders at this one, as you are experiencing classic sypmptoms of MDC issues caused by water infiltraton. Unless they already checked that and didn't tell you.

Share this post


Link to post
Share on other sites
Bozboat

did you try cleaning the cannon plug?

Share this post


Link to post
Share on other sites
Pistol Pete

Most likely the computer (MDC) that runs your Kysor Medallion gauges is faulty. My guess is that water found its way up the speedo tube into the computer and caused the failure. Water isn't supposed to get up there, but it does. Especially with the confirmed leak in your speedo hose. When there is an air leak somewhere in the system water will infiltrate all the way up to the speedo hose connections on the MDC. Trace your speedo tubes and you'll find where they connect to the MDC under the dash.

I can't believe the dealer would shrug his shoulders at this one, as you are experiencing classic sypmptoms of MDC issues caused by water infiltraton. Unless they already checked that and didn't tell you.

:plus1:

Share this post


Link to post
Share on other sites
tvano

did you try cleaning the cannon plug?

hijack on: will the boat quit running if the cannon plug is pulled? hijack off.

Share this post


Link to post
Share on other sites
Bozboat

hijack on: will the boat quit running if the cannon plug is pulled? hijack off.

well it will kill the stereo. When having gauge problems similar to the OP, wiggling the cannon plug seemed to help. While sethro and pete's idea that the computer got soaked is more likely, its doesn't cost much to check the plug before buying a computer

Share this post


Link to post
Share on other sites
electricjohn

I would look at the kill switch. A brief power interuption from the kill switch might not be noticeable on the engine running, but could be enough to cause the gauges to reboot.

Share this post


Link to post
Share on other sites
electricjohn

hijack on: will the boat quit running if the cannon plug is pulled? hijack off.

Yes, the purple ignition wire passes thru the cannon plug.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...