Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
BlitzedVLX

Prosport charger power light only (blue) while connected to charge

Recommended Posts

BlitzedVLX

I have a Prosport 12 charger connected to my starting battery and additional deep cycle battery. I have the charger connected properly with the red wire (+) and yellow (-) on the batter posts. When I connect the charger to power I am only seeing the blue power light indicator on the charger. The charger does not display a light for charging or ready. I had the batteries sitting in my basement charging all winter with the Prosport and at that time it displayed the ready indicator light. While out on the water my secondary battery will only power my stereo for a short time before running out of juice and not being able to turn the engine over. I also noticed during the remount of the Prosport that there seemed to be something loose on the inside. I am wondering if the Prosport charger is no longer working or if my secondary battery is bad (3 years of use). I will be taking the batteries to be tested sometime this week. Any input greatly appreciated.

Share this post


Link to post
Share on other sites
wdr

Blitzed, was a little hesitant about buying my PS12 as I had read a number of horror stories about the brand with even a few replaced units that went bad as well. The comments were about 50/50 love to hate and the price was right so I sprung for one as well. For me so far so good it has kept both batteries right at 12.78v all winter (in the boat). If it was good before you put everything in the boat is sounds like you might be one of the bad 50% ers hopefully not. I would recheck the connections after you get the battteries checked. If the batteries are good and the connections are good it is most likely a bad unit. Hope it is an easy fix. Bill

Share this post


Link to post
Share on other sites
BlitzedVLX

Anyone know if its possible to only charge 1 battery using the prosport 12? After disconnecting the battery and leaving battery 1 connected I touched the wires for battery 2 together and there was no spark.

Share this post


Link to post
Share on other sites
a92harley92

I don't think touching the wires together is going to give you a spark. The chargers are processor controlled. I believe they check for reverse polarity, and battery status before supplying current to the leads. They also deliver on demand... meaning they deliver more current to the battery most depleted. So... shorting the charger's leads together isn't going to tell you much.

There are also inline fuses on the leads (which would've blown by shorting out the leads (if power was supplied to the leads)). But as I said earlier... I don't think power would've been applied to the leads while they were shorted.

Have you checked the fuses to see if they've blown over the winter?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...