Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Flatland Surfer

Depth Gauge acting up

Recommended Posts

Flatland Surfer

I recently purchased an 05 23LSV and the depth gauge doesn't seem to be working? The previous owner advised me of it before purchasing. He said it had started acting up just recently. Could it be something easy to troubleshoot or should i take it into someone to have a look at it?

Share this post


Link to post
wdr

FS, depends on how it is acting up. I have seen where the epoxy holding the unit (a black puck w/ wire coming out) to the hull has come unglued and the sensor is just flopping around giving intermittent/false readings and it also could be a loose connection in the plug or corrosion. I would start at the sensor in the bilge (port/left side) by checking the mounting point and work my way up the wiring harness discounting as much of the simple fixes as possible. Depth gauges and paddle wheel issues are a common problem and don't appear to be too hard or expensive to fix. I'm sure some other members will chime in. Good luck

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...