Jump to content

Welcome to TheMalibuCrew!

As a guest, you are welcome to poke around and view the majority of the content that we have to offer, but in order to post, search, contact members, and get full use out of the website you will need to Register for an Account. It's free and it's easy, so don't hesitate to join the TheMalibuCrew Family today!

Sign in to follow this  
Mike77

Gauge Problem in 2004 WakesetterI

Recommended Posts

Mike77

I have been trying to troubleshoot and fix a problem with my 2004 Malibu Wakesetter. The 4 function gauge (fuel, battery, temp, oil) does not work properly. I have just owned the boat a little over a year. I know the previous owner added perfect pass sometime around 2006. When I started using the boat this year the 4 function guage was not working at all. At the recommendation of my local Malibu dealer, I ordered a new 4 function gauge. This did not fix the problem. I then replaced the MMDC computuer, but the problem persisted. Later this season the local Malibu dealer was looking into it and noticed that if the middle gauge (the analog speedometer with the digital hours meter) was unplugged, the 4 function gauge works perfectly. Another thing that we tried was unplugging the power to the perfect pass, to see if there was some sort of problem or short in the perfect pass system. Disconnecting the perfect pass still does not fix the problem. The digital speedometer & digital RPM on the perfect pass work fine as well as the perfect pass system. Any ideas what would cause the 4 function Malibu gauge to malfunction when the Malibu center speedometer gauge is also connected? Any idea of what to do next to troubleshoot the problem?

Thanks,

Mike

Share this post


Link to post
Mark57

I have been trying to troubleshoot and fix a problem with my 2004 Malibu Wakesetter. The 4 function gauge (fuel, battery, temp, oil) does not work properly. I have just owned the boat a little over a year. I know the previous owner added perfect pass sometime around 2006. When I started using the boat this year the 4 function guage was not working at all. At the recommendation of my local Malibu dealer, I ordered a new 4 function gauge. This did not fix the problem. I then replaced the MMDC computuer, but the problem persisted. Later this season the local Malibu dealer was looking into it and noticed that if the middle gauge (the analog speedometer with the digital hours meter) was unplugged, the 4 function gauge works perfectly. Another thing that we tried was unplugging the power to the perfect pass, to see if there was some sort of problem or short in the perfect pass system. Disconnecting the perfect pass still does not fix the problem. The digital speedometer & digital RPM on the perfect pass work fine as well as the perfect pass system. Any ideas what would cause the 4 function Malibu gauge to malfunction when the Malibu center speedometer gauge is also connected? Any idea of what to do next to troubleshoot the problem?

Thanks,

Mike

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...